
Creating Accessible PDF Documents with 
Adobe Acrobat 7.0

A Guide for Publishing PDF Documents for Use by 
People with Disabilities

�



© 2005 Adobe Systems Incorporated. All rights reserved.
Adobe, the Adobe logo, Acrobat, Adobe PDF, Capture, FrameMaker, InDesign, LiveCycle, PageMaker, and Reader are either registered trademarks or 
trademarks of Adobe Systems Incorporated in the United States and/or other countries. Apple and Mac OS are trademarks of Apple Computer, Inc., 
registered in the United States and other countries. Microsoft, Windows, and Windows XP are either registered trademarks or trademarks of Microsoft 
Corporation in the United States and/or other countries. All other trademarks are the property of their respective owners. Mention of third party products is 
for informational purposes only and constitutes neither endorsement nor recommendation. 



iii

�

Contents

Introduction
Purpose of this guide . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .1

Audience for this guide . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .1

Software described in this guide . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .1

Adobe PDF software described in this guide . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .1

Authoring applications described in this guide. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .2

Acrobat system requirements. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .2

Accessibility tools in Windows . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .2

Accessibility tools in Mac OS  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .2

Summary of the sections in this guide  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .3

Section 1: Accessibility and Adobe PDF . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .3

Section 2: Understanding tagging and document structure  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .3

Section 3: The accessibility workflow  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .3

Section 4: Creating tagged Adobe PDF documents from word-processing and  
desktop publishing applications. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .3

Section 5: Converting scans to accessible Adobe PDF content . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .3

Section 6: Creating a single tagged Adobe PDF document from multiple documents. . . . . . . . . .3

Section 7: Creating tagged Adobe PDF documents from web pages . . . . . . . . . . . . . . . . . . . . . . . . . .3

Section 8: Making Adobe PDF forms accessible  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .3

Section 9: Adding tags to Adobe PDF documents . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .3

Section 10: Evaluating Adobe PDF documents for accessibility problems  . . . . . . . . . . . . . . . . . . . . .4

Section 11: Repairing reading order and basic tagging problems . . . . . . . . . . . . . . . . . . . . . . . . . . . . .4

Section 12: Adding other accessibility features . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .4

Section 13: Fixing advanced accessibility problems  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .4

Appendix: Standard tags for Adobe PDF documents . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .4

Section 1: Accessibility and Adobe PDF
What accessibility is . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .5

Why accessibility is important for Adobe PDF documents. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .5

What makes Adobe PDF documents accessible. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .6

Section 2: Understanding tagging and document structure
How tagging and document structure affect accessibility. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .8

How to tell if an Adobe PDF document has been tagged. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .8

What tagging looks like in Acrobat . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .9

When to tag documents . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 10

Why touchup is often needed  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 11

Visit the Adobe accessibility website for more information. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 11



iv

Section 3: The accessibility workflow
Six general steps . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 12

Step 1: Start from the document you have . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 12

Step 2: If the document is a form, add fillable, accessible form fields . . . . . . . . . . . . . . . . . . . . . . . . 14

Step 3: Tag the Adobe PDF document . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 14

Step 4: Evaluate the Adobe PDF document and repair common problems  . . . . . . . . . . . . . . . . . . 14

Step 5: Add other accessibility features to the Adobe PDF document  . . . . . . . . . . . . . . . . . . . . . . . 14

Step 6: As needed, edit the tag tree to fix advanced problems . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 14

Section 4: Creating tagged Adobe PDF documents from word-processing  
and desktop publishing applications

Options for converting to Adobe PDF from authoring applications . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 16

Using Acrobat PDFMaker in non Adobe applications (Windows only) . . . . . . . . . . . . . . . . . . . . . . . 16

Using the Save As or Export command in Adobe applications (Mac OS and Windows) . . . . . . . 16

Using Adobe PDF Printer (Mac OS and Windows)  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 16

Creating tagged Adobe PDF documents from Microsoft Office 2000 or later. . . . . . . . . . . . . . . . . . . . . . 17

Tips for improving the Adobe PDF tagging and document structure in  
Microsoft Office documents . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 17

Tips for making artwork accessible  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 17

Tips for making tables accessible . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 17

Tips for making large Excel tables (worksheets) accessible . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 18

Converting Microsoft Office documents to tagged Adobe PDF documents (Windows only)  . 18

Converting Microsoft Office documents to Adobe PDF documents (Mac OS only) . . . . . . . . . . . 21

Creating tagged Adobe PDF documents from InDesign CS or later . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 21

Planning ahead to minimize tagging rework . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 21

Using threads to affect the structure of Adobe PDF tags . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 21

Using InDesign CS tags to improve accessibility . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 22

Adding accessible text to graphics  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 23

Converting InDesign CS documents to tagged Adobe PDF documents . . . . . . . . . . . . . . . . . . . . . 23

Creating tagged Adobe PDF documents from FrameMaker  7.0 . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 25

Adding alternate text to imported graphics . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 25

Converting FrameMaker documents to tagged Adobe PDF documents . . . . . . . . . . . . . . . . . . . . . 25

Creating tagged Adobe PDF documents from PageMaker 7.0 . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 26

Converting PageMaker documents to tagged Adobe PDF documents  . . . . . . . . . . . . . . . . . . . . . . 26

Finishing the Adobe PDF document for accessibility . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 27

Section 5: Converting scans to accessible Adobe PDF content
The three starting points for scans . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 28

Applying OCR to image-only Adobe PDF scans . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 29

Scanning a paper document to Adobe PDF  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 30

Converting TIFF or other image formats to Adobe PDF  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 30

Finishing the Adobe PDF document for accessibility . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 31



v

Section 6: Creating a single tagged Adobe PDF document from multiple documents
Why to combine multiple documents . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 32

Inserting, replacing, and deleting pages within an Adobe PDF document in Acrobat. . . . . . . . . . . . . . 33

Plan ahead to reduce changes to the tag tree and reading order. . . . . . . . . . . . . . . . . . . . . . . . . . . . 33

Combining files from multiple authoring applications while converting to Adobe PDF. . . . . . . . . . . . 34

Finishing the Adobe PDF document for accessibility . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 35

Section 7: Creating tagged Adobe PDF documents from web pages
What to expect when converting web pages to tagged Adobe PDF documents  . . . . . . . . . . . . . . . . . . 36

How to convert web pages to tagged Adobe PDF documents. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 37

Finishing the Adobe PDF document for accessibility . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 38

Section 8: Making Adobe PDF forms accessible
Characteristics of accessible Adobe PDF forms  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 40

Workflows for creating forms . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 40

Which Adobe tools are you using? . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 40

What is your starting point? . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 41

Tips for working with forms. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 42

Designing the form . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 42

Writing form field descriptions  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 42

Setting and testing the tab order . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 42

Using LiveCycle Designer to create accessible Adobe PDF forms . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 42

The LiveCycle Designer workflow . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 42

Using Acrobat 7.0 Professional to make Adobe PDF forms accessible . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 44

Step 1: Add fillable form fields and descriptions . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 44

Step 2: Set the tab order . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 44

Step 3: Tag the form (if it isn’t already tagged). . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 45

Step 4: Finish the Adobe PDF document for accessibility . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 45

Using Adobe PDF Forms Access to tag Adobe PDF forms  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 45

How Adobe PDF Forms Access helps with accessibility . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 45

Tagging Adobe PDF forms by using Adobe PDF Forms Access . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 46

Section 9: Adding tags to Adobe PDF documents
What to do before you tag a document  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 48

Reviewing the document  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 49

Creating links for URLs in the document . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 49

Adding tags to an untagged document . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 49

Reading the Add Tags Report . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 50

Retagging a document, if needed  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 51

Finishing the Adobe PDF document for accessibility . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 51



vi

Section 10: Evaluating Adobe PDF documents for accessibility problems
Two tools for checking the accessibility of Adobe PDF documents . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 52

Performing an accessibility Full Check. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 53

Full Check options . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 53

Viewing the results of an accessibility Full Check . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 54

Using Full Check to check for inaccessible fonts . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 56

Using Reflow view to check reading order. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 57

Other ways to check the reading order . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 57

Finishing the Adobe PDF document for accessibility . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 58

Section 11: Repairing reading order and basic tagging problems
When to use the TouchUp Reading Order tool . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 59

How the TouchUp Reading Order tool works . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 60

How the TouchUp Reading Order tool and the Order tab work together  . . . . . . . . . . . . . . . . . . . . 61

Options for the TouchUp Reading Order tool. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 62

TouchUp Reading Order preferences . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 64

The touchup workflow—an orderly approach to repairing reading order and tags. . . . . . . . . . . . . . . . 64

Four basic techniques you must know to fix reading order problems . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 65

Selecting highlighted regions . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 65

Selecting content on the page  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 66

Applying a new tag to a selection  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 67

Changing the reading order (in the Order tab) . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 68

Fixing common problems . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 69

Fixing highlighted regions  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 69

EXAMPLE 4. Fixing improperly grouped columns  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 72

EXAMPLE 5. Fixing improperly grouped columns of varying widths . . . . . . . . . . . . . . . . . . . . . . . . . 73

Fixing reading order problems  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 75

Adding alternate text to figures and descriptions to form fields. . . . . . . . . . . . . . . . . . . . . . . . . . . . . 80

Fixing basic table problems  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 82

Starting over on a page . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 84

Finishing the Adobe PDF document for accessibility . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 84

Section 12: Adding other accessibility features
Other accessibility features in Acrobat  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 85

Setting the tab order . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 86

Adding bookmarks . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 86

Adding accessible links . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 87

Creating a link by using the Create Link command . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 88

Adding alternate text to links  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 88

Setting the document language . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 89

Setting security settings so they don’t interfere with screen readers  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 90

Adding a watermark to an Adobe PDF document. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 90

Finishing the Adobe PDF accessibility workflow . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 91

Going the extra mile for accessibility. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 91



vii

Section 13: Fixing advanced accessibility problems
When to use the techniques in this section . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 93

How to read an Adobe PDF document’s tag tree. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 93

The tag tree hierarchy . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 93

Finding a tag and its corresponding content . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 95

Creating tags for links that you made active late in the workflow . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 96

Adding alternate text to links . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 97

Rearranging tags . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 98

Deleting tags. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 98

Adding new tags . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 99

Adding expansion text to abbreviated terms  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 100

Setting the language for specific paragraphs or words. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 101

Making tables accessible  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 102

Understanding the proper hierarchy of a table . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 102

The workflow for tagging tables . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 104

Checking and fixing the reading order of complex pages . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 104

Appendix: Standard tags for Adobe PDF documents
An extensible tags architecture . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 106

Block-level elements  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 106

Container elements . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 106

Heading and paragraph elements . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 107

Label and list elements. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 107

Special text elements  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 107

Table elements  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 107

Inline-level elements . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 108

Special inline-level elements. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 108



1

Introduction

Purpose of this guide
This guide provides a framework and instructions for properly preparing Adobe® PDF® (Portable Document Format) 
documents and fillable PDF forms for access by users with disabilities such as blindness, low vision, and mobility 
impairment. By following the workflow approach and tasks that are outlined in this guide, you can use Adobe 
Acrobat® 7.0 to create PDF documents that people can read by using conventional assistive technology (such as 
screen magnifiers or screen readers) or the accessibility features that are built into Acrobat 7.0 and Adobe Reader® 7.0 
(such as the Read Out Loud feature and Reflow view).

This guide is designed for use alongside Acrobat 7.0 Help. Each section offers practical explanations, specific 
workflow recommendations, and relevant step-by-step instructions for achieving accessibility with PDF documents. 
As needed, the text also directs you to appropriate sections of Acrobat 7.0 Help for instructions on basic techniques 
with Acrobat. The bulk of this guide applies to Acrobat 7.0 Professional, although some features and tools are also 
available in Acrobat 7.0 Standard. 

To better understand how people with disabilities will experience your accessible PDF documents, consult this 
guide’s companion document, Using Accessible PDF Documents with Adobe Reader 7.0: A Guide for People with 
Disabilities. You can download the document from www.adobe.com/accessibility.

Audience for this guide
This guide is written primarily for three audiences: 

• People who are creating source documents that are meant to become accessible Adobe PDF documents

• People who want to improve the accessibility of existing PDF documents and interactive PDF forms

• People who want to test the accessibility of the PDF documents they have already created

Software described in this guide
This guide provides information about using Acrobat software to optimize Adobe PDF documents for accessibility. 
Because the best results come from planning for accessibility before you convert documents to PDF, this guide also 
provides basic tips on how to prepare documents for optimal accessibility in popular word-processing and desktop 
publishing tools. 

Note: For best results when you are creating and reading PDF documents, be sure to use the most current version of 
Acrobat software, as well as the most current version of the authoring applications that you use. For information about 
ordering Acrobat products, visit www.adobe.com/products/acrobat.

Adobe PDF software described in this guide
• Acrobat 7.0 Professional. This application provides a full complement of tools for producing and repairing Adobe 

PDF documents for accessibility. You can use it to tag PDF documents, edit tags, optimize reading order, add a full 
range of accessibility features, and repair accessibility problems for PDF documents that are generated from almost 
any source. The breadth of its feature set makes Acrobat Professional the recommended application for achieving 
accessibility for PDF documents. Most of the information in this guide applies to Acrobat 7.0 Professional.

www.adobe.com/accessibility
www.adobe.com/products/acrobat


2ADOBE ACROBAT 7.0
Introduction

• Acrobat 7.0 Standard. This application includes limited support for achieving accessibility with PDF. You can use 
it to apply one-time-only tagging of untagged PDF documents, to perform a quick check on the extent of accessi-
bility in a PDF document, and to set basic accessibility functionality. Because Acrobat Standard lacks tools for 
editing tags and adding other accessibility features, this application is not recommended for those who want to 
create accessible PDF documents. Acrobat 7.0 Standard supports only a few of the techniques that this guide 
describes.

• Adobe LiveCycle™ Designer. This application is ideal for creating interactive PDF forms and making them acces-
sible; it is available separately or as part of Acrobat 7.0 Professional.

• Adobe PDF Forms Access™. This application adds tags to untagged, fillable PDF forms; it is available as part of the 
Adobe Acrobat Capture® 3.0 Agent Pack.

Authoring applications described in this guide
• Microsoft® Office 2000 or later 

• Adobe InDesign® CS 

• Adobe FrameMaker® 7.0

• Adobe PageMaker® 7.0

Acrobat system requirements
You can use Acrobat 7.0 on a computer that is running Apple® Mac OS® X v10.2.8 or later, Microsoft Windows® 2000, 
or Windows XP®. For specific product system requirements, visit the Adobe website at 
www.adobe.com/products/acrobat/acrrsystemreqs.html. 

Accessibility tools in Windows 
The Windows 2000 and Windows XP operating systems have built-in accessibility tools that provide increased or 
alternative access to information on the computer screen. You may want to use these tools when you are testing the 
accessibility of PDF documents. The two primary accessibility tools in Windows are the following:

• Narrator, a light version of a screen reader

• Magnifier, a screen magnification tool

To use Narrator, Magnifier, or other Windows accessibility tools, choose Start > All Programs > Accessories >  
Accessibility.

To change operating system options that relate to accessibility, choose Start > Control Panel > Accessibility Options.

For more information on the accessibility tools in Windows 2000 or Windows XP, visit the Microsoft accessibility 
website at www.microsoft.com/enable. 

Accessibility tools in Mac OS 
The Mac OS operating system has built-in tools that provide increased or alternative access to information on the 
computer screen. You may want to use these tools when you are testing the accessibility of PDF documents.

To modify accessibility preferences, choose Apple menu > System Preferences > Universal Access, and then select the 
category to change.

For more information on the accessibility tools in Mac OS X, visit the Apple accessibility website at 
www.apple.com/disability. 

www.adobe.com/products/acrobat/acrrsystemreqs.html
www.microsoft.com/enable
www.apple.com/disability
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Summary of the sections in this guide

Section 1: Accessibility and Adobe PDF
This section defines accessibility, its importance to individuals who read Adobe PDF documents, and the character-
istics of accessible PDF documents. 

Section 2: Understanding tagging and document structure
This section describes the basics of tagging and how tagging and document structure affect accessibility. 

Section 3: The accessibility workflow
This section identifies the various workflows that you can follow when you are making accessible Adobe PDF 
documents. Each workflow includes cross-references to the sections of this guide that can help you achieve accessi-
bility for the type of document from which you’re starting. 

Section 4: Creating tagged Adobe PDF documents from word-processing and desktop publishing 
applications
This section provides an overview of the options that are available for converting files to Adobe PDF from authoring 
applications, and offers tips for preparing files for optimal tagging and accessibility before converting files to PDF. 
By using the accessibility and document-structuring features (if any) that are available in an authoring application, 
you can often minimize, if not eliminate, the amount of follow-up work you must do in Acrobat 7.0 to optimize the 
accessibility of PDF documents. 

Section 5: Converting scans to accessible Adobe PDF content
This section explains the three ways that you can use Acrobat 7.0 to bring scanned documents into the Adobe PDF 
accessibility workflow: by applying optical character recognition (OCR) to existing PDF scans, by scanning paper 
documents directly to PDF and applying OCR, and by converting scanned image files to PDF and applying OCR. 
You must apply OCR to all PDF documents that originate from scans, so that you can prepare the text and graphics 
for editing and accessibility.

Section 6: Creating a single tagged Adobe PDF document from multiple documents
This section describes how to combine multiple documents into a single Adobe PDF document either during or after 
conversion to PDF. It also explains the effect of these changes on the tag tree, and how to plan ahead when combining 
documents, so as to avoid as much repair of the tag tree as possible.

Section 7: Creating tagged Adobe PDF documents from web pages
This section describes how to convert HTML web pages to tagged Adobe PDF documents either directly from 
Internet Explorer or from HTML pages that you have saved to a hard drive.

Section 8: Making Adobe PDF forms accessible
This section describes the characteristics of accessible Adobe PDF forms and the three most frequently used methods 
for creating them: by using Adobe LiveCycle Designer, by using the Forms tools in Acrobat 7.0 Professional, and by 
using Adobe PDF Forms Access. 

Section 9: Adding tags to Adobe PDF documents
This section describes the basic steps for adding tags to untagged Adobe PDF documents in Acrobat. Although using 
Acrobat to tag a document is not the optimal method for preparing a PDF document for accessibility, it is a 
mandatory step when you do not have access to the source file of an untagged PDF document. 
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Section 10: Evaluating Adobe PDF documents for accessibility problems
This section describes the two Acrobat tools that you should use for checking the extent of accessibility in Adobe PDF 
documents. These tools enable you to identify figures that are missing alternate text and pages that have reading 
order problems. It also highlights global accessibility problems, such as whether all the fonts in the document are 
accessible to screen readers. 

Section 11: Repairing reading order and basic tagging problems 
This section describes how to use the TouchUp Reading Order tool to assess and fix reading order problems and basic 
tagging issues that can interfere with accessibility. It also explains how to use the tool to add alternate text to figures 
and descriptions to form fields.

Section 12: Adding other accessibility features
This section describes how to add other accessibility features to an Adobe PDF document, including accessible links 
and document navigation features. It also describes how to set a document language, set security settings so they 
don’t interfere with assistive technology, and add a watermark to tagged PDF documents.

Section 13: Fixing advanced accessibility problems
This section is for advanced users who need to edit the tag tree of an Adobe PDF document to add specific accessi-
bility features or to fix complex accessibility problems. You can edit the tag tree to create tags for links that you added 
late in the workflow, add alternate text to links, improve the accessibility of complex tables, remove obsolete tags, 
rearrange the tags of entire pages at a time, and perform other detailed changes on tags. 

Appendix: Standard tags for Adobe PDF documents
This section describes the standard tag types that apply to tagged Adobe PDF documents. These standard tags 
provide assistive technology with a base set of concepts to use in interpreting document structure and presenting 
content logically to a user.
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Section 1: Accessibility and 
Adobe PDF

This section defines accessibility, its importance to individuals who read Adobe PDF documents, and the characteristics 
of accessible PDF documents. 

What accessibility is
Accessibility enables individuals with disabilities—such as people with blindness, low vision, or mobility impair-
ments—to read, hear, and interact with computer-based information and content with or without the aid of assistive 
technology.

A document is considered accessible if its contents can be accessed by anyone, not just by people who can see well and 
use a mouse. 

For instance, people with low vision or blindness may rely on screen magnifiers, screen readers that convert text to 
speech or Braille output, or other assistive technology to present the contents of a document that they want to read. 
For these people, visual indicators of a document’s structure—such as different font sizes to distinguish headings—
often cannot help them interpret reading order. An accessible document has built-in information that enables 
assistive technology to interpret the document’s structure and to present the information in a logical reading order.

Similarly, people with mobility impairments may require an alternative keyboard, an alternative pointing device, or 
voice input software to navigate the document. They may be able to see a document but be unable to use a mouse to 
position a text insertion point to fill in a form field. An accessible document for these people has support for 
keyboard navigation, as well as a preset tab order that makes moving from field to field in a form easier.

Accessible Adobe PDF documents tend to benefit all users. For instance, the same underlying document structure 
that enables a screen reader to properly read a PDF document aloud also enables any user to reflow complex 
documents in a single column in Acrobat or Adobe Reader for easier reading. This same functionality also enables 
users to read PDF documents on handheld devices, such as cell phones and personal device assistants (PDAs). 
Similarly, the preset tab order that is part of an accessible PDF form helps all users complete the form more easily.

Why accessibility is important for Adobe PDF documents
By creating accessible Adobe PDF documents, you can broaden your readership to include people with disabilities, 
as well as people who read PDF documents on handheld devices. You can also help your organization comply with 
recent government mandates for accessibility, such as Section 508 of the U.S. Rehabilitation Act. 

Adobe PDF is a standard on the World Wide Web, and it is used to distribute electronic documents over corporate 
networks, by e-mail, and on digital media. Virtually any electronic document or scanned image can be converted to 
a PDF document by using Acrobat software, and anyone can read these documents by using Acrobat or the free 
Adobe Reader software. Many corporations, educational institutions, and government agencies use PDF to 
distribute documents to the public or within their organizations. 
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Adobe is committed to providing solutions that improve the accessibility of Acrobat, Adobe Reader, and the content 
of PDF documents. Since 1997, for instance, Adobe has maintained the www.adobe.com/accessibility website 
(formerly access.adobe.com), which offers free PDF-to-text and PDF-to-HTML conversion services. In 2001, Adobe 
enhanced the PDF specification to enable people to create tagged PDF documents in Acrobat, and subsequent 
enhancements have extended this functionality. Assistive technology can now present the contents of tagged PDF 
documents to users in a logical reading order, as well as provide information about page elements, such as figures, 
that were once inaccessible to people with disabilities.

What makes Adobe PDF documents accessible
To be considered accessible, Adobe PDF documents must have the following characteristics. 

Note: Some authoring applications can generate PDF documents that meet most, if not all, of these accessibility criteria. 
To repair a PDF document that doesn’t meet all of these criteria, you must edit the document by using Acrobat 7.0 Profes-
sional. Acrobat 7.0 Standard supports only some of the functionality that is necessary to make PDF documents accessible.

1. The document is a searchable text file, not an image-only scan
An Adobe PDF document of a scanned piece of paper is inherently inaccessible because the content of the document 
is an image, not searchable text. Assistive technology cannot read or extract the words, users cannot select or edit the 
text, and you cannot manipulate the PDF document for accessibility. Once you properly apply optical character 
recognition (OCR) to the scanned file, however, the image becomes searchable text with selectable graphics, and you 
can apply other accessibility features to the document.

Both Acrobat 7.0 Professional and Acrobat 7.0 Standard include utilities for capturing scans and for converting 
scanned images to searchable PDF documents. 

2. The document’s form fields, if any, are accessible 
Some Adobe PDF documents are forms that a person is to complete by using a computer. To be accessible, these PDF 
forms must have interactive (fillable) form fields, descriptions of form fields that screen readers can read, and a preset 
tab order that helps users navigate among the form fields. 

To set up these features for PDF forms, you can use Acrobat 7.0 Professional or LiveCycle Designer. 

3. Document structure is indicated by tags 
Accessible Adobe PDF documents use tags to indicate the structural elements of a document—such as which page 
elements are titles, headings, figures, text, tables, and so on—and how these elements relate to each other. These tags 
are analogous to the paragraph styles, HTML tags, or XML tags you might use in a non-PDF document. Different 
kinds of assistive technology may process document structures in different ways. However, using a consistent tagging 
system nearly always produces better accessibility results for people with disabilities than if you do not use tags at all. 

You can prepare some documents for proper tagging before you convert them to PDF, or you can use Acrobat Profes-
sional (recommended) or Acrobat Standard to add tags to documents that have already been converted to PDF. 

4. Reading order is clear and easy to follow
A fourth characteristic of an accessible Adobe PDF document is that it has a logical, easy-to-follow reading order. 
Assistive technology is designed to read page content in the order in which it receives the content from an application 
such as Acrobat or Adobe Reader. If the content is not presented to the assistive technology in a logical reading order 
(such as if a heading comes after its body text, or a figure caption is not near its figure description), people with 
disabilities may not be able to understand the content. 

Tagging a PDF document usually establishes an appropriate, structured reading order. For complex PDF documents, 
you may need to fix the reading order by using Acrobat 7.0 Professional. 

www.adobe.com/accessibility
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5. Descriptive text is available for all graphics, links, and form fields
Accessible Adobe PDF documents also have descriptive text, usually called alternate text, to describe special items on 
a page, such as illustrations, graphs, charts, form fields, and links. Screen readers and other assistive technology 
typically cannot read graphical elements. By adding alternate text, you enable the technology to interpret the element 
and read a description of the element to the user. And although screen readers can state that a form field is present 
and can read URLs out loud, you can give the user a more meaningful context for navigating them if you also provide 
descriptive text about these elements. 

You must have Acrobat 7.0 Professional to add alternate text and descriptions to PDF page elements. 

6. Navigational aids are available
Accessible Adobe PDF documents also have many navigational aids for the user—links, bookmarks, useful and 
frequent headings, a detailed table of contents, and an optimized, preset tab order for forms and embedded links. 
These navigational aids enable users to go directly to a particular place in a document instead of reading through it 
page by page. 

You can set most navigational aids during conversion to PDF from authoring applications. You can set bookmarks 
and links by using Acrobat 7.0 Professional or Acrobat 7.0 Standard. 

7. A document language is specified
While some screen readers are designed to read documents in a particular language, specifying the document 
language in an accessible Adobe PDF document can benefit those screen readers that can switch to other languages 
during operation. 

You can set the document language for an entire PDF document by using Acrobat 7.0 Professional or Acrobat 7.0 
Standard. You must have Acrobat 7.0 Professional to set the document language for specific portions of a multi-
language PDF document. 

8. The document uses fonts that allow characters to be extracted to text
Another characteristic of an accessible Adobe PDF document is that the fonts within it contain enough information 
for Adobe Reader or Acrobat to correctly extract all the characters to text for purposes other than displaying text on 
the screen. For example, the application extracts characters to text when users listen to text by using a screen reader 
or the Read Out Loud tool in Adobe Reader or Acrobat, or when they copy, paste, or save text to a file. 

If the font’s underlying information is sufficient, Adobe Reader and Acrobat can extract each character correctly each 
time someone does these tasks. If the font’s information is insufficient, the application cannot substitute characters 
correctly, and the output is faulty. For instance, a screen reader or the Read Out Loud tool may seem to ignore words 
or characters, or users may get question marks, black rectangles, or similar marks when they copy, paste, or save a 
PDF file as text. 

Occasionally, a font does not contain enough information for Adobe Reader or Acrobat to correctly extract all the 
text characters. Although users can read the document on the screen as they would any other PDF document, the 
PDF document is considered inaccessible and you cannot repair it. You should stop working on it for accessibility. 

To check whether a PDF document has inaccessible fonts, you must use Acrobat 7.0 Professional. 

9. The security settings don’t interfere with screen readers
The final characteristic of an accessible Adobe PDF document is that its security settings do not interfere with screen 
readers. You can typically specify that no part of an accessible PDF document is to be copied, printed, extracted, 
commented on, or edited. The setting to restrict copying, however, could interfere with a screen reader’s ability to 
read the document, since the screen reader’s functionality depends on a sort of copying of the document’s text in 
order to play it back. For this reason, Acrobat provides an option called Enable Text Access For Screen Reader Devices 
For The Visually Impaired. 

You can apply this setting by using either Acrobat 7.0 Professional or Acrobat 7.0 Standard. 
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Section 2: Understanding tagging and 
document structure

This section describes the basics of tagging and how tagging and document structure affect accessibility. 

How tagging and document structure affect accessibility
Tagging is the backbone of all accessible documents. When you properly apply tagging and document structure in 
an accessible Adobe PDF document, you pave the way for users of assistive technology to read and navigate the 
document easily and reliably in Adobe Reader or Acrobat. 

Many people with disabilities depend on assistive technology to convey the content of a document in an order that 
makes sense. For instance, they expect a screen reader to read column 2 before column 3, to present sidebar text as 
supplemental to body copy, and to ignore unimportant content such as running headers and footers. 

Assistive technology, in turn, depends on markup systems that relay a document’s underlying structure to the 
technology in a way that enables the technology to present the output logically to the user. This markup system is 
much like the HTML or XML that a web browser uses to interpret how text and graphics elements are to appear on 
a screen. In PDF documents, the markup system is called tagging. Tagging describes the document structure of the 
PDF document so that, among other things, assistive technology can reliably present page content to people with 
disabilities.

Tagging creates a tag tree (also called a logical structure tree) in the PDF document. Each element in a tag tree repre-
sents an element on the page. Commonly tagged page elements include sections, stories, titles, headings, body text, 
links, lists, captions, and figures. A tag tree can be very detailed for documents that have complex page content. 

Tagging does not change the physical appearance of the PDF document. It is a behind-the-scenes representation of 
the document’s underlying structure. Tagging tells assistive technology which parts of a document or page to read 
first, second, third, and so on; which parts to ignore altogether (such as running footers and watermarks); and which 
parts to present as special elements (such as illustrations, charts, tables, and fillable form fields). 

Note: The same tagging and features that make a document accessible to screen readers also enable PDF pages to reflow 
correctly on the smaller screens of handheld devices, such as cell phones and PDAs.

How to tell if an Adobe PDF document has been tagged
The simplest way to find out whether an Adobe PDF document is already tagged is to check its status in Document 
Properties.

To check whether an Adobe PDF document has been tagged:

1  Open the Adobe PDF document in Acrobat 7.0.

2  Choose File > Document Properties.

3  On the Description tab, look for a Yes or No next to the Tagged PDF entry; No means that the file is untagged;  
Yes means that it is tagged.
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The Document Properties dialog box, where you can check whether a PDF document has already been tagged

What tagging looks like in Acrobat
In Acrobat Professional, you can view the tags of any Adobe PDF document by opening its tag tree. Information in 
the tag tree is organized into a hierarchical structure that is similar to the typical desktop computer interface of 
nested folders and files. Angle brackets (<   >) indicate the type of tag that has been applied to a particular element.

To view the tag tree (Acrobat 7.0 Professional only):

1  Open an Adobe PDF document that has been tagged.

2  Choose View > Navigation Tabs > Tags. This step opens the Tags tab as a floating window.

3  Optional: Dock the Tags tab to the navigation pane by choosing View > Navigation Tabs > Dock All Tabs or by 
dragging the Tags tab from the floating window to the navigation pane.

4  To expand the hierarchical list of tags, click the plus signs. To expand the entire tree, Ctrl+click (Windows) or 
Option+click (Mac OS) on the plus sign of the very first (root) tag.

You need to use the tag tree only for advanced accessibility tasks. For more information on navigating and editing 
the tag tree for accessibility, see “Section 13: Fixing advanced accessibility problems” on page 92.

Note: Some PDF documents show tags in the tag tree, even though Acrobat does not consider the file properly tagged (that 
is, the Document Properties dialog box reads No for the Tagged PDF entry). In this case, you should treat the file as an 
untagged file and tag it in Acrobat.
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The tag tree in Acrobat 7.0 Professional displays tags that represent the elements that are on a page. The hierarchy of the tags reflects the  
document’s structure. 

When to tag documents
You can tag documents during conversion to Adobe PDF (recommended) or after they have been converted to PDF. 

Tagging a document during conversion to PDF requires an authoring application that supports tagging in PDF. This 
functionality usually provides the best tagging results. Tagging during conversion enables the authoring application 
to draw from the source document’s paragraph styles or other structural information to produce a tag tree that 
reflects an accurate reading order and appropriate levels of tags. This tagging can more readily interpret the structure 
of complex layouts, such as embedded sidebars, closely spaced columns, irregular text alignment, and tables. Tagging 
during conversion to PDF can also properly tag the links, cross-references, bookmarks, and alternate text (when 
available) that are in the file. 

To tag a document after it has been converted to PDF, use the Add Tags To Document command in Acrobat 7.0. This 
command works on any untagged PDF document, such as a document that has been printed to PDF by using Adobe 
PDF Printer. Acrobat analyzes the content of the PDF document to interpret the individual page elements, their 
hierarchical structure, and the intended reading order of each page, and then builds a tag tree that reflects that infor-
mation. It also creates tags for any links, cross-references, and bookmarks that you added to the document in Acrobat.
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While the Add Tags To Document command adequately tags most standard layouts, it cannot always correctly 
interpret the structure and reading order of complex page elements, such as closely spaced columns, irregular text 
alignment, nonfillable form fields, and tables that don’t have borders. Tagging these pages by using the Add Tags To 
Document command can result in improperly combined elements or out-of-sequence tags that cause reading order 
problems in the PDF document. This limitation is another reason why generating a tagged document directly from 
an authoring application is the best way to begin the process of creating accessible PDF documents.

Why touchup is often needed
No matter which method you use to tag the Adobe PDF document, you will probably need to use Acrobat Professional 
to touch up the tagging and reading order for complex page layouts or unusual page elements. 

For instance, the Add Tags To Document command can’t always distinguish between instructive figures and 
decorative page elements such as borders, lines, or background elements. It may tag all of these as figures, even 
though they are not. Similarly, it may erroneously tag graphical characters within text, such as drop caps, as figures 
instead of including them in the tag that represents the rest of the text block. Such errors can clutter the tag tree and 
complicate the reading order that assistive technology relies on.

If you tag a document from within Acrobat Professional, the application generates an error report after it completes 
the tagging process. You can use this report to guide you as you repair tagging problems. You can identify other 
tagging, reading order, and accessibility problems for any PDF document in Acrobat Professional by using an acces-
sibility Full Check or the TouchUp Reading Order tool. 

Fixing errors in tagging and reading order requires Acrobat 7.0 Professional and the techniques that are described in 
the rest of this guide. 

Visit the Adobe accessibility website for more information
For more information about using the accessibility features in Acrobat to create accessible Adobe PDF documents, 
visit the Adobe accessibility website at www.adobe.com/accessibility. 

www.adobe.com/accessibility
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Section 3: The accessibility workflow

This section identifies the various workflows that you can follow when you are making accessible Adobe PDF 
documents. Each workflow includes cross-references to the sections of this guide that can help you achieve accessi-
bility for the type of document from which you’re starting. 

The information in this section applies to both Acrobat 7.0 Professional and Acrobat 7.0 Standard unless otherwise 
noted.

Six general steps
The workflow for making accessible Adobe PDF documents involves two major classes of documents: documents 
that have already been converted to PDF and documents that you intend to convert to PDF from major authoring 
applications. In all cases, you should first examine the document, determine its intended purpose, and use that 
analysis to determine the workflow that you apply. 

At a high level, the PDF accessibility workflow consists of these six basic steps. 

Step 1: Start from the document you have
When you’re ready to make an accessible Adobe PDF document, you generally start from one of the following 
documents: an existing PDF document; a document that was (or needs to be) scanned and converted to PDF; one 
or more word-processing or desktop publishing documents that need to be converted to PDF from authoring appli-
cations; or web (HTML) pages that you want to convert to PDF.

If the document is scan-based (a paper document, an image-only Adobe PDF document, or an image file)
Follow the instructions in “Section 5: Converting scans to accessible Adobe PDF content” on page 28 to capture or 
convert the document to Adobe PDF in Acrobat (if needed), and to apply optical character recognition (OCR) to 
convert the image to text and graphics that you can tag for accessibility. 

If the document is already in Adobe PDF (but is not an image-only scan)
If the document is a form, add fillable form fields in Acrobat Professional as described in “Section 8: Making Adobe 
PDF forms accessible” on page 39. Otherwise, tag the document as described in “Section 9: Adding tags to Adobe 
PDF documents” on page 48, and then run an accessibility Full Check to make sure that the document’s fonts are 
accessible before you proceed with other accessibility tasks. (Follow the instructions in “Section 10: Evaluating 
Adobe PDF documents for accessibility problems” on page 52.) 

If the document is not yet in Adobe PDF
Whenever possible, you should begin thinking about accessibility for Adobe PDF documents while you are creating 
the source files in an authoring application, such as a word-processing or page layout application. Planning ahead 
for accessibility during the design and formatting stages lets you prepare the file for accessibility in the authoring 
application, which yields optimal results when tagging the PDF document. Typical tasks to do in the authoring appli-
cation (if possible) include adding alternate text to graphics, optimizing tables, and applying paragraph styles or 
other document-structure features that can be converted to tags.

This guide provides tips for preparing the following types of source documents for accessibility:

• Microsoft Office or Adobe page layout files. Follow the instructions in “Section 4: Creating tagged Adobe PDF 
documents from word-processing and desktop publishing applications” on page 15. This section includes tips for 
working with files from Microsoft Word, Excel, and PowerPoint and from Adobe InDesign, FrameMaker, and 
PageMaker. It also provides instructions for converting files to tagged PDF documents from these applications. 
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• Multiple documents from multiple applications. Special circumstances apply if you intend to convert multiple 
source documents into one PDF document, or to combine pages from several PDF documents into one PDF 
document. Improperly mixing tagged and untagged documents can render the consolidated PDF document 
inaccessible. For tips on how to combine multiple files into a single PDF document for optimal accessibility, see 
“Section 6: Creating a single tagged Adobe PDF document from multiple documents” on page 32. 

• Web pages. Read “Section 7: Creating tagged Adobe PDF documents from web pages” on page 36 for instructions 
on properly converting web and HTML pages to tagged PDF documents.

Note: If you intend to design PDF forms, Adobe recommends using LiveCycle Designer, which is dedicated to the design 
of interactive and static forms. See “Section 8: Making Adobe PDF forms accessible” on page 39 for more information.

 

The PDF accessibility workflow that you use depends on the type of document that you are starting from. 
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Step 2: If the document is a form, add fillable, accessible form fields 
If the document that you create or receive is to be a fillable form, you must add fillable, accessible form fields (if they 
aren’t already present) and tag the form (if it isn’t already tagged). Read “Section 8: Making Adobe PDF forms acces-
sible” on page 39 for instructions on using the Acrobat family of products for processing and tagging Adobe PDF 
forms for accessibility.

Step 3: Tag the Adobe PDF document 
You can tag an Adobe PDF document during conversion to PDF from an authoring application, or at any time after 
conversion to PDF in Acrobat 7.0. To tag a document from the authoring application, see the sections of this guide 
that are discussed in “Step 1: Start from the document you have” on page 12.

Some PDF documents that you work with may already be tagged. If the document is not yet tagged, tag it by 
following the instructions in “Section 9: Adding tags to Adobe PDF documents” on page 48.

Step 4: Evaluate the Adobe PDF document and repair common problems
Once you have a tagged Adobe PDF document, you must evaluate the document for reading order problems, tagging 
errors, and accessibility errors, and then repair them as needed. To do these tasks, you must use the accessibility Full 
Check, the TouchUp Reading Order tool, and other features in Acrobat Professional. Follow the instructions in 
“Section 10: Evaluating Adobe PDF documents for accessibility problems” on page 52 and “Section 11: Repairing 
reading order and basic tagging problems” on page 59.

Step 5: Add other accessibility features to the Adobe PDF document
This step in the workflow includes performing tasks that include setting the document’s tab order and document 
language, adding bookmarks, and creating accessible links. Many of these tasks require Acrobat 7.0 Professional, but 
you can do some of them in Acrobat 7.0 Standard. Follow the instructions in “Section 12: Adding other accessibility 
features” on page 85.

Step 6: As needed, edit the tag tree to fix advanced problems
Some tagging problems, such as incorrectly identified table elements, require using advanced techniques to edit the 
document’s tag tree. Read “Section 13: Fixing advanced accessibility problems” on page 92 for instructions on how 
to deal with these situations. Editing tags requires Acrobat 7.0 Professional.
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Section 4: Creating tagged Adobe PDF 
documents from word-processing 
and desktop publishing applications

This section provides an overview of the options that are available for converting files to Adobe PDF from authoring 
applications, and offers tips for preparing files for optimal tagging and accessibility before converting files to PDF. 
By using the accessibility and document-structuring features (if any) that are available in an authoring application, 
you can often minimize, if not eliminate, the amount of follow-up work you must do in Acrobat 7.0 to optimize the 
accessibility of PDF documents. 

The information in this section applies to Microsoft Office 2000 or later applications (Word, Excel, and PowerPoint), 
InDesign CS or later, FrameMaker 7.0 or later, and PageMaker 7.0 or later. Information that is related to Acrobat 
applies to both Acrobat 7.0 Professional and Acrobat 7.0 Standard unless otherwise stated.

 

Where you are in the PDF accessibility workflow
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Options for converting to Adobe PDF from authoring applications
Authoring applications support one or more of the following methods for converting files to Adobe PDF. 

Using Acrobat PDFMaker in non Adobe applications (Windows only)
Many non Adobe Windows products support Acrobat PDFMaker 7.0 for creating Adobe PDF documents. This tool 
is installed as a command, menu, and/or a toolbar within many authoring applications, including Microsoft Office 
applications. Acrobat PDFMaker is installed as part of Acrobat 7.0 Professional and Acrobat 7.0 Standard. 

 

The Acrobat PDFMaker menu and buttons that appear in the interface of many non Adobe Windows applications 

Depending on how an authoring application implements PDFMaker functionality, Acrobat PDFMaker can create 
tags from a source file’s style elements (such as paragraph styles and lists). It often gives you control over how 
bookmarks, embedded cross-references, and embedded links convert to PDF for accessibility. Acrobat PDFMaker 
can also recognize alternate text that you add to graphics in the authoring application. 

Creating tagged PDF documents by using Acrobat PDFMaker generally provides better accessibility results than 
creating untagged documents and then tagging them from within Acrobat 7.0. 

Using the Save As or Export command in Adobe applications (Mac OS and Windows)
The best way to create Adobe PDF documents from Adobe applications is to use the application’s Save As command 
or Export command. Performing a typical installation of Adobe’s design and layout applications, including InDesign 
CS and PageMaker, automatically installs and configures all the necessary components for creating PDF documents.

Depending on how the application implements the PDF functionality, Adobe applications can create tags from a 
source file’s style elements (such as paragraph styles and lists); can generate a document structure and reading order 
that reflects the author’s intentions; can provide control over how bookmarks, embedded cross-references, and 
embedded links convert to PDF for accessibility; and can recognize alternate text that has been added to graphics. 

Creating tagged PDF documents by using the Save As or Export command almost always provides better accessibility 
results than creating untagged documents and then tagging them from within Acrobat 7.0. 

Using Adobe PDF Printer (Mac OS and Windows)
Many applications do not support either Acrobat PDFMaker or the ability to export tagged Adobe PDF directly from 
the application by using Save As, Export, or a similar command. For these applications, you can use Adobe PDF 
Printer, which enables you to create untagged PDF documents from any application that can print. You must then 
use Acrobat Professional to add tags, hyperlinks, and other accessibility features to the PDF document. Adobe PDF 
Printer is installed with Acrobat 7.0 Professional, Acrobat 7.0 Standard, and Adobe Acrobat Elements 7.0.

 

Adobe PDF Printer creates untagged PDF documents from any application that can print. 



17ADOBE ACROBAT 7.0
Section 4: Creating tagged Adobe PDF documents from word-processing and desktop publishing applications

Note: If you plan to combine source files from multiple authoring applications into one PDF document, to combine 
multiple PDF documents into one, or to insert new pages into a PDF document, you may need to start with untagged 
PDF documents and then tag the final PDF document once everything is consolidated. See “Section 6: Creating a single 
tagged Adobe PDF document from multiple documents” on page 32 for guidelines.

Creating tagged Adobe PDF documents from Microsoft Office 2000 or later
Microsoft Office 2000 or later applications have many features that can help you optimize files for accessibility before 
converting them to Adobe PDF. This section provides tips for using Microsoft Word, Excel, or PowerPoint to prepare 
a source file to become an accessible PDF document. 

For specific instructions on how to use the features that are mentioned in this section, consult Microsoft Office 
Online Help. 

Tips for improving the Adobe PDF tagging and document structure in Microsoft Office 
documents
• Always use paragraph styles, such as Heading 1, Heading 2, and Body Text, when formatting text. Acrobat 

PDFMaker and Acrobat 7.0 can read paragraph styles to identify structural elements during tagging.

• Use bullets and numbering to create lists and outlines. These convert well to tags.

• If the layout has two or more columns, use Word’s Columns feature (Format > Columns) to lay out the columns. 
Don’t use tabs or the Table feature to simulate multicolumn text. Columns translate cleanly to a tagged Adobe PDF 
document, while tabs and tables often require manual repair work with the TouchUp Reading Order tool or the tag 
tree in Acrobat Professional. 

• (Windows only) Create live hyperlinks and cross-references, and give them text descriptions (alternate text) 
whenever you can. Acrobat PDFMaker can convert links and cross-references to accessible links in the PDF 
document. 

• Choose sharp color contrast for all elements of Microsoft Office documents. Sharp color contrast is easier for 
people with vision impairments to read. While the user can adjust color contrast in Adobe Reader, you’ll have more 
control in the authoring application to make the contrast as clear as possible in the design.

Tips for making artwork accessible
• If you create drawings that comprise several smaller components, group the individual components into one illus-

tration. This enables Acrobat PDFMaker or Acrobat 7.0 to create one tag for the entire graphic, which simplifies 
the tagging, reading order, and creation of alternate text for the graphic in the Adobe PDF document. 

• (Windows only) Add alternate text to graphics before using Acrobat PDFMaker to convert the file to PDF (use the 
Web tab of the Format Picture dialog box). 

Tips for making tables accessible
• Create tables by using the Table feature (Table > Insert > Table) of Microsoft Office applications, rather than by 

using the Tab key or spacebar to position text on a page. Using the Table feature enables Acrobat PDFMaker and 
Acrobat 7.0 to correctly recognize and tag the content as a table.

• Use tables to display data or associated items of information, not to create or format columns.

• Whenever possible, do not create excessively deep rows in a table, and do not allow deep rows to break across pages. 
If you place a large piece of content in one cell and the cell is allowed to break across pages, the second page is often 
difficult to interpret because of blank cells to the right or left of it. Break large amounts of text into multiple rows 
as necessary. To keep a row from breaking across pages in Word, turn off the Allow Row To Break Across Pages 
option for that row.
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• On tables that span two or more pages, make headers repeat to help readers follow the flow of information. To do 
this in Word, turn on the Repeat As Header Row At The Top Of Each Page option for the table.

• If you are creating an untagged Adobe PDF document for later tagging in Acrobat 7.0, add rules around the table 
and between all columns, rows, and cells. Using rules increases the likelihood that Acrobat 7.0 can recognize the 
table as a table and properly tag it when you use the Add Tags To Document command. “White space” tables, in 
which data is organized in cells without rules, can create unexpected results during tagging, because Acrobat 
cannot readily recognize them as tables. In Windows, adding rules to tables is not necessary if you intend to create 
a tagged PDF document from the Office application; Acrobat PDFMaker can usually interpret white space tables 
correctly.

An inaccessible table design. The content in one very deep row was allowed to break across pages, which breaks the flow of information. The 
blank cells to the left of the filled cell are difficult for a screen reader to interpret. Also, the header rows do not repeat on this second page of the 
table, so a user has no frame of reference for what the content means. 

Tips for making large Excel tables (worksheets) accessible
If you have a large table (worksheet) in Microsoft Excel that is meant to become an accessible Adobe PDF document, 
you must remove any Print Titles that are listed in the Page Setup dialog box before you convert the document to 
PDF. Otherwise, neither Acrobat PDFMaker nor Acrobat 7.0 can create tags, bookmarks, or links for the file. To 
remove Print Titles in Excel, clear all cell references for the To Repeat At Top box and the Columns To Repeat At Left 
box in the Page Setup dialog box.

 

The error message that you receive during conversion to PDF if a large Excel table uses Print Titles

Converting Microsoft Office documents to tagged Adobe PDF documents (Windows only)
Once you create a document in a Microsoft Office application for Windows, you can convert it to a tagged Adobe 
PDF document by using Acrobat PDFMaker and the procedure described in this section. Unless you have created a 
form that is to have fillable form fields, do not print the document to PDF by using Adobe PDF Printer; this method 
produces an untagged PDF document and requires that you add tags and alternate text to the PDF document in 
Acrobat 7.0 Professional. 
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Note: If you have created a form that is to be fillable, first produce an untagged PDF document from the Office application 
by using Adobe PDF Printer. Add fillable form fields in Acrobat Professional, and then tag the file by using Acrobat Profes-
sional or Adobe PDF Forms Access. See “Section 8: Making Adobe PDF forms accessible” on page 39 for instructions. 

Before you convert a file to PDF, you must set the appropriate conversion settings for Acrobat PDFMaker.

Selecting PDFMaker settings before conversion (Windows only)
Acrobat PDFMaker provides a dialog box in which you can select the settings that PDFMaker uses to create an Adobe 
PDF document from a Microsoft Office application file. The information given here lists only the options that affect 
the accessibility of a PDF document. You select these options from the Settings tab, the Security tab, the Word tab, 
and the Bookmark tab of the Acrobat PDFMaker dialog box. 

• To open the Acrobat PDFMaker dialog box, start the Office application and choose Adobe PDF > Change 
Conversion Settings.

For more information about all the PDF conversion settings that are available for Acrobat PDFMaker with Microsoft 
Office files, see “About PDF conversion settings (Microsoft Office files)” in Acrobat 7.0 Help.

 

The Acrobat PDFMaker dialog box for Word for Windows, where you can select accessibility-related options on each tab

The Settings tab

The list of options on this tab varies by Microsoft Office application. The Settings tab generally has the following 
options that are related to accessibility:

• Convert Document Information. This option adds document information from the source file’s Properties dialog 
box to the Adobe PDF document. Document information includes title, subject, author, keywords, manager, 
company, category, and comments. 
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• Add Bookmarks To Adobe PDF. This option converts Word headings—and, optionally, other styles—to 
bookmarks in the Adobe PDF document. It converts Excel worksheet names to bookmarks. It converts PowerPoint 
titles to bookmarks. 

• Add Links To Adobe PDF. This option preserves links that are in the file and adds them to the PDF document. The 
appearance of the links is generally unchanged. 

• Enable Accessibility And Reflow With Tagged PDF. This option tags the PDF document (critical for accessibility).

The Security tab

The Security tab has an option that you must select for people who use screen readers: Enable Text Access For Screen 
Reader Devices For The Visually Impaired. This option overrides the document’s security settings only for the 
purpose of making the content available to assistive technology, such as screen readers. This option is on by default. 
If you intend to make other changes to security settings, be sure that this option remains selected once it becomes 
active.

To preserve links that you include in Excel and PowerPoint files, you must also select the Enable Accessibility And 
Reflow With Tagged PDF option on the Security tab in these applications.

The Word tab (Word only) 

The Word tab provides options for converting Word cross-references, tables of contents, footnotes, and endnotes to 
links in the Adobe PDF document. Converting these elements to links can make the PDF document more accessible 
for all users. 

The Bookmarks tab (Word only) 

From the Bookmarks tab, you can control whether to convert a document’s headings and other styles to bookmarks 
in the Adobe PDF document, and you can edit the hierarchy (level) of the bookmarks before conversion. The tab 
offers the following two conversion options:

• Convert Word Headings To Bookmarks. This option creates bookmarks for paragraphs that use the Heading 1, 
Heading 2, etc. styles from Word’s default style sheet. 

• Convert Word Styles To Bookmarks. This option creates bookmarks for paragraphs that use any other styles in the 
Word document. These include both Word’s non-Heading default styles and custom styles that you have created. 

Note: When one of these options has a checkmark next to it, all of that option’s elements convert to bookmarks. When you 
deselect (uncheck) a particular heading or style, none of the elements for that option convert to bookmarks.

Note: If a file contains paragraphs that are formatted with discontinuous heading sizes, Acrobat PDFMaker inserts blank 
bookmarks for each missing level.

Using Acrobat PDFMaker to create tagged Adobe PDF documents (Windows only)
Below are instructions for using Acrobat PDFMaker to convert Microsoft Word, PowerPoint, and Excel files to tagged 
Adobe PDF documents. For more detailed information about creating PDF documents from these applications, see 
“Converting Microsoft Office files (Windows)” and “Converting Microsoft Office files (Mac OS)” in Acrobat 7.0 
Help.

To convert Microsoft Office documents to accessible Adobe PDF documents: 

1  Open the file in the Microsoft Office application.

2  Start PDFMaker by doing one of the following:

• Choose Adobe PDF > Convert To PDF.
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• (For Excel files) If you want to convert all worksheets in the Excel file, choose Adobe PDF > Convert Entire 
Workbook. Otherwise, choose Adobe PDF > Convert To PDF to convert only the current worksheet.

• Select the Convert To Adobe PDF button on the toolbar.

Note for Excel files: If PDFMaker anticipates that it will have problems generating tags, links, or bookmarks from the 
Excel file, warning messages appear. You can either follow the instructions in the messages to modify the Excel file or edit 
the PDFMaker conversion settings. See “About PDF conversion settings (Microsoft Office files)” in Acrobat 7.0 Help.

3  Name and save the file. 

Converting Microsoft Office documents to Adobe PDF documents (Mac OS only)
If you have created a document in a Microsoft Office application in Mac OS, you must use Adobe PDF Printer to 
convert the file to an untagged Adobe PDF document. If the document is a form, add fillable form fields as described 
in “Section 8: Making Adobe PDF forms accessible” on page 39. Otherwise, tag the document by following the 
instructions in “Section 9: Adding tags to Adobe PDF documents” on page 48. 

Creating tagged Adobe PDF documents from InDesign CS or later
To complete the tasks in this section, you need InDesign CS or later. 

Planning ahead to minimize tagging rework
InDesign CS has many features and techniques that let you control the document structure and tagging of Adobe 
PDF documents that you create from its files. It also has tools for adding alternate text to graphics.

Two features in InDesign CS—threads and tags—provide nearly complete control over the tag structure that is used 
for accessibility purposes in PDF documents. You should not need to modify the reading order or the tags of the PDF 
document in Acrobat if you build the InDesign CS document appropriately. 

Bear in mind that more complex layouts increase the potential for problems with tagging. Decide the relevance of 
certain visual embellishments, and consider ways to provide meaningful alternate text for graphics. If you discover 
reading order or tagging problems in the PDF document, you should return to InDesign CS to repair the document 
structure, and then reexport the document to PDF. 

For more information on preparing InDesign CS files for accessibility, see “About using Acrobat structure tags for 
PDF export” in InDesign CS Help.

Using threads to affect the structure of Adobe PDF tags
InDesign CS uses threads to indicate the flow of text among visually separate frames that contain related content. A 
story in InDesign CS comprises either a single unthreaded frame or a collection of threaded frames. When you 
generate an Adobe PDF document from InDesign CS, the conversion process groups threaded frames together in the 
tag tree of the PDF document and marks the beginning of each story by inserting a <Part> tag in front of the story’s 
first frame in the tag tree. 

Appropriately specifying the story threads in InDesign CS creates appropriately grouped frames in the tag tree in the 
PDF document—which, in turn, improves how well screen readers, Acrobat accessibility tools, and other assistive 
technology can present the content to a user.

For instance, if you have a headline in one frame, and the body of an article in another frame, and you do not thread 
the frames, the tag tree will have two <Part> tags (one for each single-frame story). By threading the headline frame 
to the body frame, you enable the tag tree to have one <Part> tag for both frames, which simplifies the tag tree and 
eliminates potential ambiguity for a screen reader.
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Threading the frames of a story is particularly important if the story jumps to later pages in the layout. By using 
threading to help keep the relevant text frames together in the tag tree, you enable a screen reader to start reading a 
story on one page, “jump ahead” to a later page to complete the story, and then return to the original page to pick 
up the beginning of a different story.

When threading frames, keep the following tips in mind
• For optimal accessibility, use threading to describe the sequence of information in separate logical sections of a 

document, such as a story in a magazine, a chapter in a book, or a section in a report. When one logical section 
ends and another begins, start a new thread for the new section. 

• Thread the frames of multiple columns within the same logical section of the document, not just frames that go 
from one page to the next. Disconnected or unthreaded frames result in out-of-sequence tag structures and illogical 
document reading order, which causes problems for screen readers. 

• Leave ancillary content unthreaded. Some textual elements really do stand apart from their surrounding story. 
Examples include sidebars, pull quotes, and captions. Feel free to leave these unthreaded, so as to simplify the task 
of laying out the page, and to clarify the reading order and structure. Similarly, threading every running head or 
decorative text block results in fewer, but deeply nested, tag hierarchies that obscure the identities of the individual 
logical elements.

• Remember that you can thread text frames only; you cannot thread graphic frames (although you can put graphics 
inside the text flow as inline or anchored graphics).

• For the best results, plan ahead for threading, preferably during the initial stages of document design. Threading 
as an afterthought can sometimes be difficult and disruptive to the document layout. 

Using InDesign CS tags to improve accessibility
The tags that you add in InDesign CS are not the same as Adobe PDF tags. However, tags that you create in InDesign 
CS have a direct effect on the way that tags are subsequently generated in PDF. 

Using InDesign CS tags enables you to improve accessibility in the following two ways: 

• You can arrange InDesign CS tags for every frame in the document in a logical reading order and have those tags 
translate directly and sequentially to PDF tags during conversion. Moreover, rearranging the tags in InDesign CS 
need not affect the visual layout of the document, so you can do it at any time during your document creation 
workflow. Manipulating the reading order of tags in InDesign CS is also much easier than manipulating the reading 
order in Acrobat 7.0 Professional. 

• You can assign alternate text to graphics in the original InDesign CS document. This ability is important because 
InDesign CS documents tend to be graphics-intensive. If you don’t add alternate text in the InDesign CS tag 
structure, you must add it in Acrobat 7.0 Professional after you create the tagged PDF document.

Note: Although you can add alternate text and change the reading order of elements in Acrobat Professional, keep in mind 
that you must redo these changes every time you generate a new PDF document from the InDesign CS file. By adding 
alternate text and adjusting the reading order in the source file in InDesign CS, you can eliminate duplicate effort in 
Acrobat each time you generate a new PDF document. 

To add view tags in an InDesign CS document:

1  In InDesign CS, choose View > Structure > Show Tagged Frames to open the document tag Structure pane at the 
left. The Structure pane initially contains only a root tag.

2  From the Structure pane, choose Structure > Add Untagged Items to tag all the objects. 

3  Click the arrow next to Tags Root to expand the structure outline and to view the tags. 
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InDesign CS document tags 

For instructions on using the InDesign CS Structure pane to arrange the sequence of frame tags, see “About using 
Acrobat structure tags for PDF export” in InDesign CS Help.

Adding accessible text to graphics 
You can use the Structure pane to add alternate text to graphics in an InDesign CS document before converting the 
file to PDF. To make a graphic accessible to screen readers, apply one of the following alternate-text attributes to the 
graphic’s tag: 

• ActualText. This attribute is intended to present any words that are represented as a graphic (that is, words that 
have been made into a graphical element). You should keep ActualText short, and have the text exactly replicate 
whatever text is in the graphic. 

• Alt text. This attribute is meant to fully describe a graphic or its content to convey information about the graphic. 

For instructions on using the InDesign CS Structure pane to add alternate text to graphics tags, see “About using 
Acrobat structure tags for PDF export” in InDesign CS Help.

Converting InDesign CS documents to tagged Adobe PDF documents 
Once you have created a document in InDesign CS, you convert it to a tagged Adobe PDF document by using the 
Export command and the procedure described in the following steps. Do not create the PDF document using Adobe 
PDF Printer unless the file is to be a PDF form with fillable form fields. Adobe PDF Printer always produces an 
untagged PDF document, which means that you must add tags and alternate text to the PDF document in 
Acrobat 7.0. 

Note: If you have created a form that is to be fillable, first produce an untagged PDF document from InDesign CS by using 
Adobe PDF Printer. Add fillable form fields in Acrobat Professional, and then tag the file by using Acrobat or Adobe PDF 
Forms Access. See “Section 8: Making Adobe PDF forms accessible” on page 39 for instructions. 
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To export an InDesign CS document as an accessible PDF document: 

1  In InDesign CS, choose File > Export.

2  In the Export dialog box, select Adobe PDF in the Save As Type (Windows) or the Format (Mac OS) drop-down 
menu, and then enter a file name. 

3  Select Save. 

4  For InDesign CS, view the General pane of the Export PDF dialog box and do the following:

• In the Options section, select Acrobat 5 (PDF 1.4) from the Compatibility drop-down menu. (Earlier versions 
of Acrobat cannot read tags; if you select Acrobat 4 (PDF 1.3), the file is still readable by screen readers.)

• Select eBook Tags to generate tags for the PDF document.

5  For InDesign CS2, do the following:

• At the top of the Export PDF dialog box, select Acrobat 5 (PDF 1.4) or later from the Compatibility drop-down 
menu. (Earlier versions of Acrobat cannot read tags; if you select Acrobat 4 (PDF 1.3), the file is still readable by 
screen readers.)

• View the General pane of the Export PDF dialog box, and then select Tagged PDF to generate tags for the PDF 
document.

6  View the Security pane of the Export PDF dialog box. Security is off by default. If you need to protect the PDF 
document with a password, be sure to activate the following two options, which are useful for people who use 
screen readers:

• Enable Text Access For Screen Reader Devices For The Visually Impaired (this option is not available if you select 
Acrobat 4 compatibility for the document in step 4 above).

• Enable Copying Of Text, Images, And Other Content (activating this option is necessary only if you select 
Acrobat 4 compatibility for the document in step 4 above).

7  Select Export to start the PDF conversion process. 

 

The InDesign CS Export PDF dialog box 
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Creating tagged Adobe PDF documents from FrameMaker  7.0
To complete the tasks that are described in this section, you need FrameMaker 7.0 or later. Other accessibility-related 
information is also available in “Creating accessible documents (Windows)” in FrameMaker 7.0 Help.

Adding alternate text to imported graphics
To make a graphic accessible to screen readers in a FrameMaker document, apply one of the following alternate-text 
attributes to the graphic: 

• ActualText. This attribute is intended to present any words that are represented as a graphic (that is, words that 
have been made into a graphical element). You should keep ActualText short, and have the text exactly replicate 
whatever text is in the graphic. 

• Alternate text. This attribute is meant to fully describe a graphic or its content to convey information about the 
graphic. 

In FrameMaker, you add ActualText or alternate text to the frame of an imported graphic, not to the graphic itself. 
The frame must be an anchored frame. 

To create an anchored frame and place a graphic in it:

1  Choose Special > Anchored Frame. 

2  Select a position for the frame, and then click New Frame in the Anchored Frame dialog box.

3  Add the image file by choosing File > Import > File. Select an image, and then click Import.

To add alternate text to a graphic that is inside an anchored frame: 

1  Select the Anchored Frame and right-click to show the context menu.

2  Select Object Properties.

3  In the Object Properties dialog box, select Object Attributes. 

4  Type the Alternate text or Actual text in the appropriate box. 

Converting FrameMaker documents to tagged Adobe PDF documents
You convert FrameMaker files to tagged Adobe PDF documents by using Adobe PDF Printer and the Generate 
Acrobat Data option in the FrameMaker Print dialog box, as described in the procedure below. For details on all the 
options that are available for creating PDF documents from FrameMaker, see “HTML and Adobe PDF conversion” 
in FrameMaker 7.0 Help.

To convert a FrameMaker document to a tagged Adobe PDF document: 

1  Choose File > Print Setup.

2  In the Printer area of the Print Setup dialog box, choose Adobe PDF in the Name drop-down menu. Click OK.

3  Choose File > Print.

4  Select Generate Acrobat Data, and then click PDF Setup.

5  In the PDF Setup dialog box, select the Tags tab, and then select Generate Tagged PDF.

6  As desired, choose the paragraph styles that you want to include in the tag tree and logical structure, such as 
chapter title, head1, head2, and so forth, and then set the logical structure levels (hierarchy) of each element. You 
may also want to create settings for Bookmarks and Links by using the Bookmarks and Links tabs of the PDF Setup 
dialog box. 
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7  Click Set to accept the changes in the PDF Setup dialog box.

8  In the Print dialog box, deselect Print To File, and then click Print to generate the PDF document. 

 

The PDF Setup dialog box in FrameMaker 7.0

Creating tagged Adobe PDF documents from PageMaker 7.0
To complete these tasks, you need PageMaker 7.0 or later and either Acrobat 7.0 Professional or Acrobat 7.0 Standard 
installed on your computer. 

Converting PageMaker documents to tagged Adobe PDF documents
You create Adobe PDF documents from PageMaker by using the Export command. Unless the PageMaker document 
is to be a PDF form with fillable form fields, do not print the document to PDF by using Adobe PDF Printer; this 
method produces an untagged PDF document and requires that you add tags and alternate text to the PDF document 
in Acrobat 7.0. 

Note: If you have created a form that is to be fillable, first produce an untagged PDF document from PageMaker by using 
Adobe PDF Printer. Add fillable form fields in Acrobat Professional, and then tag the file by using Acrobat Professional or 
Adobe PDF Forms Access. See “Section 8: Making Adobe PDF forms accessible” on page 39 for instructions. 

To create accessible Adobe PDF documents from a PageMaker document: 

1  Open the PageMaker document.

2  Choose File > Export > Adobe PDF.

3  In the PDF Options dialog box, select PDF as the Save As Type.

4  In the General tab of the PDF Options dialog box, verify that the Embed Tags In PDF (For Accessibility And 
Reflow) option is selected. 

5  Click Export to generate the tagged PDF document.
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The PageMaker PDF Options dialog box with the Embed Tags In PDF option selected 

Finishing the Adobe PDF document for accessibility
Remember that creating a tagged Adobe PDF document is only part of the PDF accessibility workflow. Regardless of 
what application you use to create the PDF document, you should also perform the following steps in Acrobat 
Professional to ensure the accessibility of the PDF document: 

1  Check the PDF document for form fields, and add fillable, accessible form fields, if necessary. See “Section 8: 
Making Adobe PDF forms accessible” on page 39.

2  Tag the PDF document for accessibility (if it is not already tagged). See “Section 9: Adding tags to Adobe PDF 
documents” on page 48.

3  Perform an accessibility Full Check and verify that the fonts in the document are accessible. See “Section 10: Evalu-
ating Adobe PDF documents for accessibility problems” on page 52. 

4  Use the TouchUp Reading Order tool to fix reading order and other problems. See “Section 11: Repairing reading 
order and basic tagging problems” on page 59. 

5  Add other features to optimize the PDF document for accessibility. See “Section 12: Adding other accessibility 
features” on page 85. 

6  Edit the tag tree to repair complex problems. See “Section 13: Fixing advanced accessibility problems” on page 92.
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Section 5: Converting scans to 
accessible Adobe PDF content

This section explains the three ways that you can use Acrobat 7.0 to bring scanned documents into the Adobe PDF 
accessibility workflow: by applying optical character recognition (OCR) to existing PDF scans, by scanning paper 
documents directly to PDF and applying OCR, and by converting scanned image files to PDF and applying OCR. 
You must apply OCR to all PDF documents that originate from scans, so that you can prepare the text and graphics 
for editing and accessibility.

The information in this section applies to Acrobat 7.0 Professional and Acrobat 7.0 Standard.

 

Where you are in the PDF accessibility workflow 

The three starting points for scans
When you convert scans to accessible Adobe PDF documents, you will start with one of the following three 
documents: 

• An image-only PDF scan that needs OCR processing (the content is one large graphic when you select it by using 
the Select tool) 

• A paper document that needs scanning to PDF and OCR processing

• A TIFF (or other image format) file that needs conversion to PDF and OCR processing
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Acrobat 7.0 has tools to enable you to bring all three types of documents into the PDF accessibility workflow. 

A. Scanned text is an image of the words and is inaccessible to people with disabilities. B. Searchable text is available for editing and manipula-
tion, much as if the author used a keyboard to type the text. Searchable text is accessible to people with disabilities. 

Applying OCR to image-only Adobe PDF scans
Scanned documents that have been saved as image-only Adobe PDF documents are not accessible to screen readers 
until you apply OCR to them. The content is merely a graphic, rather than text that assistive technology can read and 
interpret. To assistive technology, an image-only page is a blank page. 

Acrobat Professional and Acrobat Standard can apply OCR to convert image-only scans to accessible content. You 
must, however, activate the Formatted Text & Graphics setting in the OCR tool, so that Acrobat processes both the 
text and the graphics on a page. When this setting is active, words become searchable text that Acrobat can analyze 
and tag for document structure, and graphics become selectable figures to which you can add alternate text for acces-
sibility.

To apply OCR to Adobe PDF scans that are intended for the PDF accessibility workflow:

1  Open the image-only Adobe PDF scan in Acrobat 7.0.

2  Select Document > Recognize Text Using OCR. 

3  In the Recognize Text dialog box, click Edit.

4  In the Recognize Text Settings dialog box, select Formatted Text & Graphics from the PDF Output Style list box, 
and then click OK. 

5  In the Recognize Text dialog box, select a page range, and then click OK.

 

Select the Formatted Text & Graphics option when you are applying OCR to create an accessible PDF document.
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In some instances, Recognize Text Using OCR can’t recognize all the text. These instances relate directly to the clarity 
of the scanned material. For example, Recognize Text Using OCR might interpret a smudge on a page as suspect text. 
Similarly, the OCR dictionary in Acrobat may have difficulty identifying characters, so it considers them suspect or 
questionable. You can examine, confirm, or correct suspect text in Acrobat either one suspect at a time or for all 
suspects at once.

For detailed information on applying OCR and checking for OCR suspects in scanned PDF documents, see 
“Creating Adobe PDF documents from paper documents” in Acrobat 7.0 Help. 

Scanning a paper document to Adobe PDF
You can use a scanner and Acrobat 7.0 to scan a paper document directly to Adobe PDF by using the File > Create 
PDF > From Scanner command in Acrobat. 

You can apply OCR at the same time that you scan the document, or afterward by using the Recognize Text Using 
OCR feature. If you apply OCR while capturing the scan, you must activate the Formatted Text & Graphics setting, 
as previously described in “Applying OCR to image-only Adobe PDF scans” on page 29, so that Acrobat processes 
both text and graphics. In this workflow, this setting is available when you click Settings in the Create PDF From 
Scanner dialog box.

Applying OCR while scanning a document; click the Settings dialog box to select the Formatted Text & Graphics option and create an accessible 
PDF document from the scan.

After applying OCR, you must verify the accuracy of the OCR by checking for OCR suspects. 

For detailed information on scanning documents directly to PDF, applying OCR, and checking for OCR suspects, 
see “Creating Adobe PDF documents from paper documents” in Acrobat 7.0 Help. 

Note: If your enterprise has a large volume of legacy paper documents that have not yet been scanned and converted to 
PDF, consider purchasing Adobe Acrobat Capture 3.0 and the Tag Adobe PDF Agent, so you can process them all at once 
into searchable, tagged PDF archives. See www.adobe.com/products/acrobat for more information. 

Converting TIFF or other image formats to Adobe PDF
Scanned files that have not been saved directly to Adobe PDF are generally saved in an image format, such as TIFF, 
JPEG, or GIF. To bring these files into the PDF accessibility workflow, you can open them in Acrobat 7.0, save them 
as PDF, and then apply OCR to convert the image to accessible content. 

Acrobat 7.0 can open and convert BMP, GIF, JPEG, JPEG2000, PCX, PNG, and TIFF images. To open them, use 
either the File > Open command or the File > Create PDF > From File command. When you apply OCR, be sure to 
select the Formatted Text & Graphics option in the Recognize Text Settings dialog box, so that Acrobat can recognize 
both graphics and text on the page. See “Applying OCR to image-only Adobe PDF scans” on page 29.

www.adobe.com/products/acrobat
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For instructions on converting files to PDF, applying OCR, and checking for OCR suspects, see “Creating Adobe PDF 
documents from paper documents” in Acrobat 7.0 Help. 

Note: If your enterprise has a large number of already-scanned files that have not yet been converted to PDF, consider 
purchasing Adobe Acrobat Capture 3.0 and the Tag Adobe PDF Agent, so you can process them all at once into searchable, 
tagged PDF documents. See www.adobe.com/products/acrobat for more information. 

Finishing the Adobe PDF document for accessibility
Remember that converting an Adobe PDF scan to accessible text and graphics is only part of the PDF accessibility 
workflow. You should also perform the following steps in Acrobat Professional to ensure the accessibility of the PDF 
document: 

1  Check the PDF document for form fields, and add fillable, accessible form fields, if necessary. See “Section 8: 
Making Adobe PDF forms accessible” on page 39.

2  Tag the PDF document for accessibility (if it is not already tagged). See “Section 9: Adding tags to Adobe PDF 
documents” on page 48.

3  Perform an accessibility Full Check and verify that the fonts in the document are accessible. See “Section 10: Evalu-
ating Adobe PDF documents for accessibility problems” on page 52. 

4  Use the TouchUp Reading Order tool to fix reading order and other problems. See “Section 11: Repairing reading 
order and basic tagging problems” on page 59. 

5  Add other features to optimize the PDF document for accessibility. See “Section 12: Adding other accessibility 
features” on page 85. 

6  Edit the tag tree to repair complex problems. See “Section 13: Fixing advanced accessibility problems” on page 92.

www.adobe.com/products/acrobat
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Section 6: Creating a single tagged 
Adobe PDF document from multiple 
documents

This section describes how to combine multiple documents into a single Adobe PDF document either during or after 
conversion to PDF. It also explains the effect of these changes on the tag tree, and how to plan ahead when combining 
documents, so as to avoid as much repair of the tag tree as possible.

The instructions in this section apply to both Acrobat 7.0 Professional and Acrobat 7.0 Standard unless otherwise 
noted.

 

Where you are in the PDF accessibility workflow 

Why to combine multiple documents
Typically, more than one person is working on a document or project. One person might be writing content, while 
another is creating a cover page with artwork. These people may be using different applications to create the final 
Adobe PDF content. In this situation, you can combine PDF documents by using two methods: 

• Insert, replace, and delete pages from multiple PDF documents to create one PDF document from within Acrobat

• Combine source documents from multiple authoring applications while you convert them to one PDF document
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Inserting, replacing, and deleting pages within an Adobe PDF document 
in Acrobat
In Acrobat 7.0 you can insert pages from one Adobe PDF document into another, replace pages from one PDF 
document with those of another, and delete pages. 

Plan ahead to reduce changes to the tag tree and reading order
When you consolidate multiple Adobe PDF documents in order to produce one tagged PDF document, start with 
all untagged PDF documents or all tagged PDF documents. Combining tagged and untagged PDF documents results 
in a partially tagged PDF document that is not accessible to people with disabilities. Users will be completely unaware 
of the pages that do not have tags. 

If you are starting from a mix of tagged and untagged PDF documents, tag the untagged files before proceeding. If 
you intend to use all untagged PDF documents, add tags to the document after you are finished inserting, replacing, 
and deleting pages. See “Section 9: Adding tags to Adobe PDF documents” on page 48 for instructions.

Keep in mind that when you combine PDF pages or documents by inserting, replacing, and deleting PDF pages, 
Acrobat accepts the existing tags into the tag tree of the consolidated PDF document in the following manner:

• When you insert pages into a PDF document, Acrobat adds the tags (if any) for the new pages to the end of the tag 
tree, even if you insert the new pages at the beginning or the middle of the document. 

• When you replace pages in a PDF document, Acrobat adds the tags (if any) from the incoming pages to the end of 
the tag tree, even if you replace pages at the beginning or the middle of the document. Acrobat retains the tags (if 
any) for the replaced pages. 

• When you delete pages from a PDF document, Acrobat retains the tags (if any) of the deleted pages. 

Pages whose tags are out of order in the tree can cause problems for screen readers. Screen readers read tags in order 
down the tree, and therefore they might not reach the tags for an inserted page until they reach the end of the tree. 
To fix this reading order problem, you would typically need to rearrange the tag tree to put large groups of tags in 
the same reading order as the pages themselves. You can, however, plan ahead to avoid the need for this advanced 
step in the workflow.

The best strategy is to arrange a workflow in which you are always inserting pages to the end of a PDF document and 
building the document from front to back in sequence. For example, if you create a title page PDF document 
separately from the PDF document that contains the body of the text, add the body PDF document to the title page 
PDF document, even though the body document is much larger to process. This puts the tags for the body of the text 
after the tags for the title page, and eliminates the need for you to rearrange the tags later in Acrobat Professional.

Note: The tags that remain from a deleted or replaced page don’t connect to any content in the document. In essence, they 
are large pieces of “empty” tag tree sections. These unneeded tags increase the file size of the document, slow down screen 
readers, and can make screen readers present confusing results. You should delete tags of deleted pages from the tag tree. 
For instructions, see “Section 13: Fixing advanced accessibility problems” on page 92.

To insert, replace, and delete pages in a PDF document, you use the Document > Insert Pages, Document > Replace 
Pages, and Document > Pages > Delete commands, respectively. See “Combining Adobe PDF documents” and 
“Deleting and replacing pages” in Acrobat 7.0 Help.
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Insert pages at the end of a PDF document for the most efficient PDF accessibility workflow.

Combining files from multiple authoring applications while converting to 
Adobe PDF
With Acrobat 7.0, you can combine multiple files from different applications in a single operation in order to create 
a single Adobe PDF document. With this technique, for instance, you can combine word-processing files with slide 
presentations, spreadsheets, and web pages. 

Acrobat Professional is recommended for this method of combining documents, because you generally need to 
modify the reading order and tag tree afterward. The conversion process doesn’t always correctly interpret the 
document structure for the combined document because the files that are being assembled often use varying 
formats. 

Note: You can also use this method to combine multiple PDF documents into a single PDF document. However, because 
this conversion process tags all files while converting them, it also attempts to retag the content of tagged PDF documents. 
This tagging often results in a reading order and tag tree that require extensive repair. For best results, combine only 
untagged PDF documents when you use this workflow, and then tag the resulting document in Acrobat 7.0.

To combine multiple source files into a single Adobe PDF document, do one of the following: 

• In Acrobat, choose File > Create PDF > From Multiple Files. You can select the files that you want to combine to 
create the Adobe PDF document and put the files in the desired order for the new PDF document. During 
conversion, Acrobat opens each application, creates a tagged PDF document, and assembles these documents into 
a single tagged PDF document. See “Creating Adobe PDF files from multiple files” in Acrobat 7.0 Help for more 
details.

• Place all the files that are to be combined into one folder and select all the files in Windows Explorer or in the Mac 
OS desktop. Open the context menu and choose Combine In Adobe Acrobat. This command launches Acrobat and 
then opens the Create PDF From Multiple Documents dialog box, where you can set the desired order of the files 
for the new PDF document.
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The Create PDF From Multiple Documents dialog box 

Finishing the Adobe PDF document for accessibility
Remember that creating a tagged Adobe PDF document from multiple documents is only one part of the PDF acces-
sibility workflow. You should also perform the following steps in Acrobat Professional to ensure the accessibility of 
the PDF document: 

1  Check the PDF document for form fields, and add fillable, accessible form fields, if necessary. See “Section 8: 
Making Adobe PDF forms accessible” on page 39.

2  Tag the PDF document for accessibility (if it is not already tagged). See “Section 9: Adding tags to Adobe PDF 
documents” on page 48.

3  Perform an accessibility Full Check and verify that the fonts in the document are accessible. See “Section 10: Evalu-
ating Adobe PDF documents for accessibility problems” on page 52. 

4  Use the TouchUp Reading Order tool to fix reading order and other problems. See “Section 11: Repairing reading 
order and basic tagging problems” on page 59. 

5  Add other features to optimize the PDF document for accessibility. See “Section 12: Adding other accessibility 
features” on page 85. 

6  Edit the tag tree to repair complex problems. See “Section 13: Fixing advanced accessibility problems” on page 92.
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Section 7: Creating tagged Adobe PDF 
documents from web pages

This section describes how to convert HTML web pages to tagged Adobe PDF documents either directly from 
Internet Explorer or from HTML pages that you have saved to a hard drive.

The information in this section applies to Acrobat 7.0 Professional. 

 

Where you are in the PDF accessibility workflow 

What to expect when converting web pages to tagged Adobe PDF 
documents
An Adobe PDF document that you create from a web page is only as accessible as the HTML source code that it is 
based on. For example, if the web page relies on tables for its layout design (as many web pages do), the HTML code 
for the table may not flow in the same logical reading order as a tagged PDF document would require, even though 
the HTML code is sufficiently structured to display all the elements correctly in a browser. 

Depending on the complexity of the web page, you may need to do extensive repairs by using the TouchUp Reading 
Order tool or editing the tag tree in Acrobat 7.0 Professional. 

To produce the most accessible PDF documents from web pages, first create the web pages to read in a logical reading 
order in their HTML code. For best results, employ the Web Content Accessibility Guidelines that are published by 
the World Wide Web Consortium (W3C). The guidelines are available on the W3C website, www.w3.org.

www.w3.org
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How to convert web pages to tagged Adobe PDF documents
You can create tagged Adobe PDF documents from web pages in two ways: 

• Choose File > Create PDF > From Web Page in Acrobat Professional. This method enables you to convert one 
web page at a time, an entire website at once, or HTML pages that you have stored on your hard drive. Click Settings 
to open the Web Page Conversion Settings dialog box, where you can select the Create PDF Tags option to tag the 
document. 

• (Windows only) Use the Convert Web Page To PDF command of the Adobe PDF button in Internet Explorer 

5.01 or later. This button is installed in the browser’s toolbar when you install Acrobat 7.0 Professional or 
Acrobat 7.0 Standard. This method converts one web page at a time to a tagged PDF document directly from  
the web.

The Create PDF From Web Page dialog box in Acrobat Professional (left), and the Web Page Conversion Settings dialog box (right), where you 
can generate tags for the PDF document

 

The Adobe PDF button on the Internet Explorer toolbar

For more information about the many options that are available when you convert to PDF from web pages, see 
“Converting web pages in Internet Explorer (Windows)” and “Creating Adobe PDF documents from downloaded 
web pages” in Acrobat 7.0 Help. 
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Finishing the Adobe PDF document for accessibility
Remember that creating a tagged Adobe PDF document from a web page is only the first part of the accessibility 
workflow. You should also perform the following steps in Acrobat Professional to ensure the accessibility of the PDF 
document: 

1  Perform an accessibility Full Check and verify that the fonts in the document are accessible. See “Section 10: Evalu-
ating Adobe PDF documents for accessibility problems” on page 52. 

2  Use the TouchUp Reading Order tool to fix reading order and other problems. See “Section 11: Repairing reading 
order and basic tagging problems” on page 59. 

3  Add other features to optimize the PDF document for accessibility. See “Section 12: Adding other accessibility 
features” on page 85. 

4  Edit the tag tree to repair complex problems. See “Section 13: Fixing advanced accessibility problems” on page 92.
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Section 8: Making Adobe PDF forms 
accessible

This section describes the characteristics of accessible Adobe PDF forms and the three most frequently used methods 
for creating them: by using Adobe LiveCycle Designer, by using the Forms tools in Acrobat 7.0 Professional, and by 
using Adobe PDF Forms Access. 

The instructions in this section apply to Acrobat 7.0 Professional, LiveCycle Designer (available separately or as part 
of Acrobat 7.0 Professional), and Adobe PDF Forms Access (a standalone utility that is bundled in the Acrobat 
Capture 3.0 Agent Pack). 

Note: This section offers instructions and tips that are relevant to making PDF forms more accessible, but a full treatment 
of how to create forms is significantly beyond the scope of this guide. As appropriate, this section directs you to specific 
sections of Help for the products described. See “Creating Adobe PDF forms” in Acrobat 7.0 Help for detailed information 
about the types of form fields that are used in PDF documents, and the various actions and calculations that they  
can trigger.

 

Where you are in the PDF accessibility workflow 
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Characteristics of accessible Adobe PDF forms
To be considered accessible, an Adobe PDF form must have the following five characteristics: 

• Fillable form fields, so that users can complete the form on a computer

• Descriptions for the form fields, so that screen readers can read the fields to users

• A preset tab order, so that users can navigate logically from form field to form field

• A complete set of tags, so that screen readers can read the entire document to the user

• Other standard accessibility features as needed for navigating and reading the contents of the rest of the document 
(for example, bookmarks, accessible links, and so on)

This section describes the workflow for achieving the first four characteristics for PDF forms. See Sections 10 
through 13 for instructions on optimizing the rest of the PDF document for accessibility. 

Workflows for creating forms 
The workflows for creating accessible Adobe PDF forms vary based on what Acrobat tools you are using and where 
you’re starting from—a blank page, an untagged PDF form, or a tagged PDF form.

Which Adobe tools are you using?
Adobe provides the following three applications for producing accessible Adobe PDF forms:

• Acrobat 7.0 Professional. Use this application to open untagged or tagged PDF forms (except PDF forms that are 
created from LiveCycle Designer) in order to add fillable form fields, such as text boxes, check boxes, and buttons. 
Then use the application’s other tools to make the form accessible by adding descriptions to form fields, tagging 
untagged forms, setting the set tab order, manipulating tags, and performing the other PDF accessibility tasks that 
are described in this guide.

• Adobe PDF Forms Access. Use this tool to open and tag untagged PDF forms that you created by using Acrobat 
Professional, and to manipulate the tags of these forms. You can then open the tagged PDF document in Acrobat 
Professional and complete the rest of the accessibility tasks that are described in this guide.

• LiveCycle Designer. Use this product to design and build new forms or to import untagged PDF forms and make 
their form fields fillable and accessible. You can deploy forms in tagged PDF, XML, and other formats from 
LiveCycle Designer. 

Note: If you often process complex, untagged PDF forms, consider purchasing Adobe PDF Forms Access. Its tagging 
feature is optimized for interpreting forms content, and its tags editor is much easier to use than the tags editor in Acrobat 
Professional for correcting tagging problems in forms.

Deciding between LiveCycle Designer and Acrobat Professional
Once you create or edit an Acrobat form in LiveCycle Designer, it becomes a LiveCycle Designer file—it is no longer 
a PDF document that you can open, edit, or manipulate in Acrobat Professional. Both Acrobat and Adobe Reader 
can open and read PDF forms that you create from LiveCycle Designer. These PDF forms, however, do not include 
permissions to modify the file, so you cannot perform any other accessibility tasks that are described in this guide on 
PDF forms that you generate from LiveCycle Designer. 

You should therefore use LiveCycle Designer only for PDF documents that are intended to contain only form-based 
information. Do not use it to add form fields to a document that combines pages of narrative with an occasional page 
that has form fields. In this case, you should use Acrobat Professional to add the form fields, and then use Acrobat 
Professional to complete the accessibility tasks that are described in this guide for the rest of the document’s content.
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Forms capabilities of Adobe applications

What is your starting point?

If you are creating a new form
You can create new forms by using LiveCycle Designer or an authoring application, such as Microsoft Word or 
InDesign CS. LiveCycle Designer enables you to create a new form that has fillable and accessible form fields, and 
then to deploy the form in one of several file formats, including XML-based formats for deployment on the web. 
Using LiveCycle Designer is the recommended method for producing complex forms or forms that are linked to 
databases. See “Using LiveCycle Designer to create accessible Adobe PDF forms” on page 42. 

Another alternative is to use an authoring application to create the form. Most authoring applications that you can 
use to design forms do not retain their fillable form fields when you convert the files to Adobe PDF. You will therefore 
need to use the Forms tools in Acrobat Professional to add fillable form fields. 

Moreover, if you tag the form during conversion to PDF, the authoring application may generate inappropriate tags 
for the text labels of the form fields. In a complex form, for instance, the text labels for all the fields may run together 
into a single line that screen readers can’t interpret as individual labels. Such reading order problems can require 
time-consuming work in Acrobat Professional to split the labels apart. In this case, producing an untagged PDF form 
from the authoring application is sometimes the better course. You can then use the Forms tools in Acrobat Profes-
sional to add fillable form fields before you tag the entire document. 

Some forms, however, are straightforward enough that you can produce a tagged PDF document from the authoring 
application and do only light touchup in Acrobat Professional after you add the fillable form fields. 

The simplicity or complexity of the source file in its authoring application may tip the balance between generating 
an untagged PDF form, and then using Acrobat Professional to add fillable form fields and tag the form, versus 
generating a tagged PDF form, and then using Acrobat Professional to add fillable form fields and correct poor 
tagging.

If you are starting from a form that is already in Adobe PDF
The process of making any Adobe PDF form accessible involves a few basic steps—add fillable form fields, add 
descriptions to the fields, set the tab order for the fields, and tag the document (if it is not already tagged). If a PDF 
form is already tagged when you receive it, you must manually tag the form fields that you create in Acrobat Profes-
sional. This step is covered later in the PDF accessibility workflow, in “Section 11: Repairing reading order and basic 
tagging problems” on page 59. 
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Tips for working with forms

Designing the form
Forms tend to have relatively complex layouts compared to documents that have a simple, single-column structure. 
The success that an application has in analyzing and tagging a form depends largely on the original formatting and 
layout, and on the types of fields that it uses.

When you are designing a form, include headings, instructions, and fields in which users are to enter data. At a 
minimum, give each field a label. Also add special instructions for fields that need them. You can draw lines or boxes 
next to the labels in the source file to indicate where you intend to place the fillable fields in Acrobat Professional. 
Use graphics tools to draw lines and boxes—do not use characters, such as underscores and vertical bars, because 
these text characters can confuse screen readers. 

Writing form field descriptions
Adding descriptions to form fields enables screen readers to identify the fields to users. Users hear the description 
read aloud when they tab to the field. Write descriptions that are terse but complete. For example, for a first-name 
field, type a description that is something like “First name.” Descriptions should not contain instructions such as 
“Enter . . . .” 

Setting and testing the tab order
The tab order for form fields enables people with disabilities to use a keyboard to move from field to field in a logical 
order. In Adobe PDF forms, you should set the tab order to Use Document Structure. You can test a form’s tab order 
by using the following keyboard commands: 

• Press Tab to move focus to the next field. 

• Press Shift+Tab to move focus to the previous field. 

• Press the spacebar to select options. 

• Press the arrow keys to select radio button options or list items. 

Using LiveCycle Designer to create accessible Adobe PDF forms
LiveCycle Designer is an application that is dedicated to the design of electronic forms. You can use LiveCycle 
Designer to create forms from a blank page or template, or to import Adobe PDF forms for further work. LiveCycle 
Designer saves forms in multiple formats, and enables you to bind forms to XML schemas, XML sample data files, 
databases, and web services. 

The LiveCycle Designer workflow
The workflow for creating an accessible form by using LiveCycle Designer has four basic steps. 

Step 1: Design and build the form
If you have Acrobat 7.0 Professional, you can launch LiveCycle Designer by choosing Advanced > Forms > Create 
New Form. LiveCycle Designer provides a New Form Assistant to walk you through the setup of the new form. See 
“Creating accessible forms” in LiveCycle Designer 7.0 Help for specific tips on designing forms for people with 
disabilities.

Step 2: Add descriptions to form fields 
In LiveCycle Designer, descriptions are called Custom Screen Reader Text. Screen readers read this text for a field if 
you also select Custom from the Screen Reader Precedence drop-down menu in the Accessibility palette of LiveCycle 
Designer. See “About the Accessibility palette” in LiveCycle Designer 7.0 Help for instructions.



43ADOBE ACROBAT 7.0
Section 8: Making Adobe PDF forms accessible

 

Adding a form field description in the Accessibility palette of LiveCycle Designer 

Step 3: Set and test the tab order for form fields
You can set the tab order field by field in LiveCycle Designer. Setting the tab order is one of the final tasks that you 
should do when you are creating a form. See “Setting the tabbing order” in LiveCycle Designer 7.0 Help.

Step 4: Save the form as a tagged Adobe PDF form
LiveCycle Designer saves forms in several formats, including static (nonfillable) Adobe PDF (Acrobat) forms, 
dynamic (fillable) PDF forms, and Adobe XML forms. To create a tagged form, you must select Generate Accessi-
bility Information (Tags) For Acrobat in the Save As dialog box. See “Saving forms for Acrobat and Adobe Reader” 
in LiveCycle Designer 7.0 Help for information on these different formats.

 

Selecting a file format and tagging a form in the Save As dialog box of LiveCycle Designer 

Note: Once you save the form as a tagged PDF form, you are finished with the accessibility workflow for a LiveCycle 
Designer form. You can open and fill out the form in Adobe Reader or Acrobat, but you cannot use Acrobat Professional 
to edit the form, or to perform the other accessibility tasks that are described in this guide. 
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Using Acrobat 7.0 Professional to make Adobe PDF forms accessible
In Acrobat Professional, you can open untagged and tagged Adobe PDF forms, add fillable form fields, set the tab 
order, add alternate text to form fields, and tag the forms (if they are not already tagged). You can also edit the tags 
of any tagged PDF form by using the TouchUp Reading Order tool or the tag tree. 

When you are making PDF forms accessible by using Acrobat Professional, the workflow has the following steps.

Step 1: Add fillable form fields and descriptions
Acrobat Professional has a Forms toolbar that provides numerous tools for creating fillable form fields, such as 
buttons, check boxes, list boxes, and text boxes. You can add a description to a field as you create the field. Just type 
the description into the Tooltip box in the General tab of the field’s Properties dialog box. Screen readers will read 
this text aloud to the user. (You can also use the TouchUp Reading Order tool to add descriptions to form fields, as 
described in “Section 11: Repairing reading order and basic tagging problems” on page 59.) 

See “Creating Adobe PDF forms” in Acrobat 7.0 Help for instructions on using the Forms tools.

 

The Forms toolbar of Acrobat Professional 

 

Adding a description as you create a form field—type the description into the Tooltip box for the field.

Step 2: Set the tab order 
Although Acrobat Professional offers manual control over tab order, set the tab order to use the document’s 
structure. This setting provides the greatest accessibility.

To set the tab order of form fields to use the document structure:

1  Open the Pages tab of the navigation pane. 

2  Select all the pages by pressing Ctrl+A (Windows) or Command+A (Mac OS).

3  From the Pages tab, choose Options > Page Properties. 

4  In the Page Properties dialog box, select the Tab Order tab, and then select Use Document Structure.
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Step 3: Tag the form (if it isn’t already tagged)
You can quickly check whether an Adobe PDF document is tagged by using the File > Document Properties 
command. At the bottom of the Document Properties dialog box, look for Yes or No next to the Tagged PDF entry. 

If the PDF form is already tagged, you must use the TouchUp Reading Order tool in Acrobat Professional to tag each 
form field that you added in step 1 of this workflow. This tool also enables you to fix any reading order problems of 
the text labels for the form fields. (For instance, you may need to split merged lines of fields into individual fields.) 
See “Section 11: Repairing reading order and basic tagging problems” on page 59 for instructions. 

If the form is untagged and you have Adobe PDF Forms Access, use this utility to tag the form by following the steps 
below in “Using Adobe PDF Forms Access to tag Adobe PDF forms.” Otherwise, use the Add Tags To Document 
command in Acrobat Professional to tag the form by following the instructions in “Section 9: Adding tags to Adobe 
PDF documents” on page 48. 

To edit the tags for the form fields, use either Adobe PDF Forms Access (recommended) or Acrobat Professional.

Step 4: Finish the Adobe PDF document for accessibility 
Remember that creating a tagged and fillable form is only part of the Adobe PDF accessibility workflow. You should 
also perform the following steps in Acrobat Professional to ensure the accessibility of the PDF document: 

1  Perform an accessibility Full Check and verify that the fonts in the document are accessible. See “Section 10: Evalu-
ating Adobe PDF documents for accessibility problems” on page 52. 

2  Use the TouchUp Reading Order tool to fix reading order and other problems. See “Section 11: Repairing reading 
order and basic tagging problems” on page 59. 

3  Add other features to optimize the PDF document for accessibility. See “Section 12: Adding other accessibility 
features” on page 85. 

4  Edit the tag tree to repair complex problems. See “Section 13: Fixing advanced accessibility problems” on page 92.

Using Adobe PDF Forms Access to tag Adobe PDF forms
Adobe PDF Forms Access is a standalone application that is part of the Acrobat Capture 3.0 Agent Pack. It can be 
run alongside Acrobat Professional or as an agent (plug-in) within an Acrobat Capture workflow. 

With Adobe PDF Forms Access, you can open untagged Adobe PDF forms that are already fillable, tag the forms for 
optimal document structure, and then easily edit the tags. 

How Adobe PDF Forms Access helps with accessibility 
The Adobe PDF Forms Access tool automates and optimizes the tagging process that is required to create accessible 
Adobe PDF forms from untagged PDF forms.

The tagging functionality of Adobe PDF Forms Access is specifically designed to recognize the objects and structures 
in a form and to link content with fillable form fields to make forms accessible. Adobe PDF Forms Access also speeds 
up the task of manually creating tags for data fields in forms. This facility is particularly helpful as the number of 
fields in the form increases. 

You can modify and rearrange the tag structure of the tagged form. A useful feature of Adobe PDF Forms Access is 
the ability to import a tag structure from another document to the current document. This feature enables you to 
preserve the PDF tag structure of a form through successive updates without completely reconstructing the tag 
structure in the updated document. 
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Tagging Adobe PDF forms by using Adobe PDF Forms Access 
Adobe PDF Forms Access is designed to tag Adobe PDF forms that you have prepared in Acrobat Professional. Follow 
the workflow in “Using Acrobat 7.0 Professional to make Adobe PDF forms accessible” on page 44 to add fillable 
fields in the PDF document. Also add descriptions to the fields and set the tab order to Use Document Structure. 

Step 1: Tag and edit the tags of the Adobe PDF form
The Adobe PDF Forms Access tool automatically creates tags for a form as you open the form in the Adobe PDF 
Forms Access tool. It shows the tags for one page at a time. 

Note: If Adobe PDF Forms Access cannot process a PDF document, the document already has tags in the tag tree. If the 
Document Properties dialog box reads Yes for the Tagged PDF entry, do not attempt to retag the document. If the 
Document Properties dialog box reads No for the Tagged PDF entry, you must delete all the tags from the tree to enable 
Adobe PDF Forms Access to tag the form. Open the document in Acrobat Professional, view the tag tree in the Tags tab, 
and choose Options > Clear Tags to delete any tags that are in the tree. Save the document, and then reopen the form in 
Adobe PDF Forms Access.

The tag tree of an Adobe PDF Forms Access document 

The success that Adobe PDF Forms Access has in analyzing and tagging a form depends largely on the form’s original 
formatting and layout, and on the types of fields that the form uses. Because forms are complex and contain many 
components, the initial tagging process generally produces a tag tree hierarchy that does not completely reflect the 
logical reading order of the form. 

Sometimes, for instance, the tagging process doesn’t place form elements such as identifying numbers, text labels, or 
special instructions in the right sequence in the tag tree. Because a screen reader reads the elements of a tag tree in 
order down the tree, you may need to edit the tree to reflect a logical sequence, so that the final order makes sense to 
a listener. 

For instructions on editing the tag tree, see Adobe PDF Forms Access Help.
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Step 2: Complete the form processing
You can edit, save, close, and reopen an Adobe PDF form in Adobe PDF Forms Access as often as you like until the 
tags are the way you want them. However, you must complete the form processing and lock the changes by choosing 
File > Finish.

Once you save a PDF form by using the Finish command, you cannot load the form back into Adobe PDF Forms 
Access for further editing. You may want to use the Save As command to save a copy of the file with your final tag 
tree structure just before issuing the Finish command. If you decide to edit the document again later in Adobe PDF 
Forms Access, you can use the copy. As an alternative, you can also open and edit the form fields or the tags by using 
Acrobat 7.0 Professional.

Step 3: Finish the Adobe PDF document for accessibility 
Remember that creating a tagged and fillable form is only part of the Adobe PDF accessibility workflow. You should 
also perform the following steps in Acrobat Professional to ensure the accessibility of the PDF document: 

1  Perform an accessibility Full Check and verify that the fonts in the document are accessible. See “Section 10: Evalu-
ating Adobe PDF documents for accessibility problems” on page 52. 

2  Use the TouchUp Reading Order tool to fix reading order and other problems. See “Section 11: Repairing reading 
order and basic tagging problems” on page 59. 

3  Add other features to optimize the PDF document for accessibility. See “Section 12: Adding other accessibility 
features” on page 85. 

4  Edit the tag tree to repair complex problems. See “Section 13: Fixing advanced accessibility problems” on page 92.
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Section 9: Adding tags to Adobe PDF 
documents

This section describes the basic steps for adding tags to untagged Adobe PDF documents in Acrobat. Although using 
Acrobat to tag a document is not the optimal method for preparing a PDF document for accessibility, it is a 
mandatory step when you do not have access to the source file of an untagged PDF document. 

Both Acrobat 7.0 Professional and Acrobat 7.0 Standard can add tags to untagged PDF documents. Due to the 
limited ability of Acrobat Standard to modify and improve the initial tagging, however, Adobe strongly recommends 
using Acrobat Professional for tagging PDF documents. The information in this section applies to both Acrobat 
Professional and Acrobat Standard.

 

Where you are in the PDF accessibility workflow 

What to do before you tag a document
Creating a tagged Adobe PDF document directly from an authoring application is the best way to make PDF 
documents accessible. If you have an untagged PDF document, however, you can use the Add Tags To Document 
command in Acrobat to tag the file. 

Before you add tags to a PDF document, you should review the document’s readiness for tagging and have Acrobat 
convert all URLs in the document to live links, so that Acrobat can recognize and properly tag the links.
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Reviewing the document
Before tagging an Adobe PDF document, open it in Acrobat 7.0 and review the following: 

• Is the PDF document a scanned document (the content is one large graphic when you select it by using the Select 
tool)? If so, first convert the document to accessible text and graphics, as described in “Section 5: Converting scans 
to accessible Adobe PDF content” on page 28. 

• Does the PDF document have form fields that are not yet fillable? If so, follow the instructions in “Section 8: 
Making Adobe PDF forms accessible” on page 39 to add fillable, accessible form fields, and then tag the document.

• Is the file really untagged? Choose File > Document Properties, and look at the Tagged PDF setting. If the setting 
is No, follow the instructions in this section to tag the document. If the setting is Yes, go to “Section 10: Evaluating 
Adobe PDF documents for accessibility problems” on page 52 to perform the next step in the PDF accessibility 
workflow.

Note: A PDF document may show tags in the Tags tab, even though Acrobat does not consider the file to be properly tagged 
(that is, the Document Properties dialog box reads No for the Tagged PDF entry). Treat this document as an untagged 
document. Using the Add Tags To Document command in Acrobat removes these obsolete tags.

• Does the PDF document contain URLs that are to be active? If so, create links from the URLs as described in this 
section before you tag the document. 

Creating links for URLs in the document 
For URLs to be accessible to screen readers, you must convert them to active (“live”) links and make sure that they 
are correctly tagged in the Adobe PDF document. To automate this process, Acrobat provides the Create From URLs 
In Document command, which finds all URLs in the document, converts them to active links, and prepares them for 
proper tagging in Acrobat. You can create links for the entire document or for certain pages. 

Activating links globally before you tag a PDF document eliminates the work of activating the links one by one in the 
tagged document. Doing this step now is especially important if the PDF document contains many URLs—for 
example, if it has an extensive resource or reference section, or if URLs are sprinkled throughout the document. 

To convert URLs to active links, choose Advanced > Links > Create From URLs In Document. 

The Create Web Links dialog box opens from the Create From URLs In Document command and enables you to prepare URLs for proper tagging.

Adding tags to an untagged document
You can add tags to untagged Adobe PDF documents in either Acrobat 7.0 Professional or Acrobat 7.0 Standard. 
Using Acrobat Professional is recommended, because you can also edit the tags. Tagging in Acrobat Standard is a 
one-time-only task, and you cannot view or edit the tag tree.

To add tags to an untagged Adobe PDF document: 

1  Open the Adobe PDF document in Acrobat 7.0.

2  Choose Advanced > Accessibility > Add Tags To Document.
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Acrobat analyzes each page to determine the page’s various elements and roles, their proper reading order, and which 
tag to apply to each element. It then adds a tag tree to the document to represent these page elements and their 
reading order. In Acrobat 7.0 Professional, a report of the results also appears in the How To window after the process 
is complete, so that you can edit any tags that need repair. 

Note: Recognizing the structure of complex documents can be very difficult for the tagging functionality in Acrobat. Pages 
that contain elements such as closely spaced columns, irregular text alignment, noninteractive form fields, and tables 
without borders may require considerable touchup using the features in Acrobat Professional and the instructions in 
Sections 10 to 13 of this guide.

Reading the Add Tags Report
The Add Tags Report opens in the How To window after you tag a document in Acrobat 7.0 Professional. The report 
lists potential errors by page, provides a navigational link to each error in the document, and offers suggestions for 
fixing the errors. 

You should assess the context of an error before following a particular suggestion for fixing it. For example, the report 
might state that an element that has been tagged as a figure requires alternate text to make it accessible. When you 
examine the figure in its context on the page, you may decide that the figure is a background design element instead 
of a graphic that conveys valuable content to the user. If it’s a nonessential figure, you would change the Figure tag 
to a Background tag; if the figure is important for the reader, you would add the missing alternate text. 

Note: The Add Tags Report highlights tagging-related problems only, and it is a temporary file that you cannot save. You 
can assess other tagging, reading order, and accessibility problems by using an accessibility Full Check. This tool generates 
a full accessibility report that you can save and refer to later. The accessibility Full Check is available in Acrobat Profes-
sional. See “Section 10: Evaluating Adobe PDF documents for accessibility problems” on page 52.

Use the links in the Add Tags Report to find potential problems that Acrobat Professional encountered during the tagging process.
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Retagging a document, if needed
Acrobat can retag an already tagged document after you first clear all existing tags from the tree. 

To clear all tags in an Adobe PDF document: 

1  Open the Adobe PDF document in Acrobat 7.0 Professional.

2  Open the Tags tab of the navigation pane and select the root (topmost) tag.

3  In the Tags tab, choose Options > Delete tag.

Finishing the Adobe PDF document for accessibility
Remember that creating a tagged Adobe PDF document is only part of the PDF accessibility workflow. You should 
also perform the following steps in Acrobat Professional to ensure the accessibility of the PDF document: 

1  Perform an accessibility Full Check and verify that the fonts in the document are accessible. See “Section 10: Evalu-
ating Adobe PDF documents for accessibility problems” on page 52. 

2  Use the TouchUp Reading Order tool to fix reading order and other problems. See “Section 11: Repairing reading 
order and basic tagging problems” on page 59. 

3  Add other features to optimize the PDF document for accessibility. See “Section 12: Adding other accessibility 
features” on page 85. 

4  Edit the tag tree to repair complex problems. See “Section 13: Fixing advanced accessibility problems” on page 92.
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Section 10: Evaluating Adobe PDF 
documents for accessibility problems

This section describes the two Acrobat tools that you should use for checking the extent of accessibility in Adobe PDF 
documents. These tools enable you to identify figures that are missing alternate text and pages that have reading 
order problems. It also highlights global accessibility problems, such as whether all the fonts in the document are 
accessible to screen readers. 

The information in this section applies to both Adobe Acrobat 7.0 Professional and Acrobat 7.0 Standard unless 
otherwise noted.

Where you are in the PDF accessibility workflow 

Two tools for checking the accessibility of Adobe PDF documents 
Acrobat provides several ways for you to check the extent of accessibility of an Adobe PDF document. When you are 
first evaluating a document, the two features that you will use most often are:

• The accessibility Full Check (Acrobat Professional only). Use this tool to find figures that need alternate text and 
other problems. Full Check generates a detailed report of all problems, together with suggestions for fixing them. 

• Reflow view. Use this feature to quickly check the reading order of a document by flowing a page as one column 
of text. 
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Note: The TouchUp Reading Order tool in Acrobat Professional enables you to closely examine and fix reading order 
problems. This tool is described in detail in “Section 11: Repairing reading order and basic tagging problems” on page 59.

You should perform an accessibility Full Check on a tagged PDF document before you begin repairing the document, 
and occasionally thereafter to test your progress. You should also check the document one final time when you have 
finished the PDF accessibility workflow. 

Note: To fix problems with reading order or to add missing descriptions to figures, form fields, and links, you must use the 
TouchUp Reading Order tool or the tag tree in Acrobat 7.0 Professional. 

Performing an accessibility Full Check
In Acrobat 7.0 Professional, you can run an accessibility Full Check, which analyzes a document to find inaccessible 
content. This tool lets you choose the kinds of accessibility problems to look for, and it creates a detailed error report 
after the checking is complete. The error report provides links (or comments) to specific errors on a page, as well as 
suggestions for fixing them. You can save these reports for later reference. 

• To run an accessibility Full Check, choose Advanced > Accessibility > Full Check. 

Note: Performing an accessibility Full Check on an entire document at once can be time-consuming. If checking a 
document is taking too long, you can stop the process by pressing Esc, and then choose a smaller page range in the  
Accessibility Full Check dialog box.

Full Check options
The Accessibility Full Check dialog box includes the following options:

• Alternative Descriptions Are Provided. Select this option to check for tagged figures that are missing alternate 
text.

• Text Language Is Specified. Select this option to check for paragraphs that do not have a language specified for 
them. Setting the language for an entire document in the Document Properties dialog box corrects all errors that 
are related to this option.

• Reliable Character Encoding Is Provided. Select this option to check for fonts that are inaccessible to screen 
readers. 

• All Content Is Contained In The Document Structure. Select this option to check for page elements that Acrobat 
may have overlooked during tagging. Adding these elements to the tag tree (if necessary) ensures that a screen 
reader can present the content to a user.

• All Form Fields Have Descriptions. Select this option to check for form fields that are missing descriptions.

• List And Table Structure Is Correct. Select this option to ensure that the tags that have been generated for lists and 
tables meet the requirements of tagged PDF.

• Tab Order Is Consistent With The Structure Order. Select this option to ensure that the tags properly reflect the 
document’s structure.

To correct errors that Full Check reports, you must use the TouchUp Reading Order tool or edit the tag tree in 
Acrobat Professional. Instructions for these tasks are provided in Sections 11and 13 of this guide.
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The Accessibility Full Check options dialog box 

Viewing the results of an accessibility Full Check
You can choose to view the results of an accessibility Full Check as links in the How To window, or as comments that 
are keyed to the errors on the pages. 

Acrobat automatically saves an HTML version of an Accessibility Report in the same folder in which the source 
Adobe PDF document is saved. You can also use the Browse button to select the directory in which the report is saved. 
You can open a previously run report by choosing Advanced > Accessibility > Open Accessibility Report. (The report 
has the same file name as its source PDF document, except that the file name ends in .html.)

You should assess the context of an error before following a particular suggestion for fixing it. For example, the report 
might state that an element that has been tagged as a figure requires alternate text to make it accessible. When you 
examine the figure in its context on the page, you may decide that the figure is a background design element instead 
of a graphic that conveys valuable content to the user. If it’s a nonessential figure, you would change the Figure tag 
to a Background (artifact) tag; if the figure is important for the reader, you would add the missing alternate text. 
Similarly, Full Check might report that a running header is not part of the tag tree. You can leave the running header 
as it is, or you can modify it to be a Background object so that a screen reader does not vocalize it. 

Viewing Full Check results in the How To window
If you select Create Accessibility Report in the Accessibility Full Check dialog box, Acrobat Professional opens the 
Accessibility Report in the How To window to the right of the document after Full Check is complete. Links in the 
Accessibility Report take you to the location of each inaccessible element. The associated content is highlighted in 
the document pane. 
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Viewing the results of an accessibility Full Check as an Accessibility Report in the How To window

Viewing comments created by Full Check 
If you select Create Comments In Document in the Accessibility Full Check dialog box, you can view the contents of 
the report as comments that put a box around suspect areas on the page. You can set the comments to appear in one 
of the following two ways: 

• As pop-ups when you position the mouse over an area on the page. To activate pop-up comments, choose Edit > 
Preferences > Commenting, and then select Automatically Open Pop-ups On Mouse Rollover. 

• As a list in the Comments tab of the navigation pane. 

Note: You must delete all accessibility comments from the PDF document after you repair the accessibility issues. To delete 
all comments at once, open the Comments tab, select any comment, and then choose Edit > Select All, or press Ctrl+A 
(Windows) or Command+A (Mac OS). Then press the Delete key. 

Viewing the results of an accessibility Full Check as pop-up comments
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Viewing the results of an accessibility Full Check as listed comments

Using Full Check to check for inaccessible fonts
The Full Check feature can determine whether the fonts in the document are accessible to assistive technology, such 
as screen readers. Fonts must contain enough information for Adobe Reader and Acrobat to correctly extract all the 
characters to text for assistive technology. If one or more fonts don’t allow for the correct extraction of all the 
characters, the Adobe PDF document is inaccessible, and you should stop working on the document for accessibility. 
Although this kind of accessibility problem is rare, checking for it will save you time and effort.

To check for font problems, select Reliable Character Encoding Is Provided in the Accessibility Full Check dialog box. 
Depending on the font error, Full Check may identify the pages where the problems exist and highlight specific 
characters on the page. You should decide whether the font problems are critical. For instance, if the problem 
characters are the bullets in a list, the document is probably still accessible. If Full Check reports a font problem but 
doesn’t call out any instances of it, go to File > Document Properties and review the fonts that are listed in the Fonts 
tab. If you have access to the source file of the PDF document, consider substituting different fonts for those that are 
currently used, and then regenerating the PDF document. 

 

A Full Check report indicating that the PDF document has font problems that make the document inaccessible to assistive technology
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Using Reflow view to check reading order
One quick way to check the order of elements in a document is to temporarily reflow the text in Reflow view. In this 
view, Acrobat flows the tagged Adobe PDF document one page at a time as a single column of text that fits across the 
width of the document pane. Reflow view lets you check whether other stories are interrupting the flow of text that 
spans columns or pages. You cannot save or edit a document while it is in Reflow view. 

Acrobat displays most, but not all, text in Reflow view. Form fields, comments, digital signature fields, and page 
artifacts, such as page numbers, headers, and footers, do not display in Reflow view. Also, Acrobat does not reflow 
pages that contain both readable text and form fields or digital signature fields. 

When properly tagged and structured, headings and columns (left) flow in a logical reading order in Reflow view (right). 

If the reflowed document doesn’t read in the order that you expect, use the TouchUp Reading Order tool to locate 
and fix the problem areas. See “Section 11: Repairing reading order and basic tagging problems” on page 59 for 
instructions.

To use Reflow view:

• To reflow a document, choose View > Reflow.

• To exit Reflow view, either choose View > Reflow again, or select any other view, such as Actual Size, Fit Page, or 
Fit Width.

Other ways to check the reading order
Acrobat and Adobe Reader offer several features that people with disabilities use to read accessible Adobe PDF 
documents. You can use some of these same features, as well as other tools that are available only in Acrobat, to check 
the reading order of content and to obtain valuable information about how users will experience your document. 
You may find one of the following features easier to work with than another:

• Turn on Read Out Loud. Use this feature to hear the document read aloud according to the current reading order. 
(To turn on this feature, choose View > Read Out Loud. See “Using the Read Out Loud feature” in Acrobat Help 
for more information.) This feature is also available in Adobe Reader.

• Save a document as accessible text. Use this feature to visually confirm the reading order. (Choose File > Save As 
and select Text (Accessible) in the Save As Type drop-down menu. Then read the document in a word-processing 
application.) This feature is also available in Adobe Reader.

• Save the document as HTML. Use this technique to view the reading order as a web page. (Choose File > Save As 
and select one of the HTML options in the Save As Type drop-down menu.)
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• Open the PDF document while using a screen reader, if you have one. Use this method to listen to the reading 
order of the document. Adobe Reader also supports screen readers.

• (Acrobat Professional only) Use the TouchUp Reading Order tool. Use this tool to view the reading order as 
numbered overlays on a page, as well as to repair reading order problems. See “Section 11: Repairing reading order 
and basic tagging problems” on page 59.

• (Acrobat Professional only) Skim through the Tags tab in the navigation pane. Use this technique to highlight 
each element on a page in the order in which a screen reader receives it. (In the Tags tab, choose Options > 
Highlight Content, and then expand all the tags by pressing Ctrl [Windows] or Option [Mac OS] as you click the 
plus sign [+] of the topmost tag. Use the Up and Down Arrow keys to select tags and view their corresponding 
content on the page.)

Note: If you have been editing the PDF document, you must save the document before you can use the first four options 
above.

Finishing the Adobe PDF document for accessibility
Remember that checking the extent of accessibility in a document is only one part of the Adobe PDF accessibility 
workflow. You should also perform the following steps in Acrobat Professional to ensure the accessibility of the PDF 
document: 

1  Use the TouchUp Reading Order tool to fix reading order and other problems. See “Section 11: Repairing reading 
order and basic tagging problems” on page 59. 

2  Add other features to optimize the PDF document for accessibility. See “Section 12: Adding other accessibility 
features” on page 85. 

3  Edit the tag tree to repair complex problems. See “Section 13: Fixing advanced accessibility problems” on page 92.
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Section 11: Repairing reading order 
and basic tagging problems

This section describes how to use the TouchUp Reading Order tool to assess and fix reading order problems and basic 
tagging issues that can interfere with accessibility. It also explains how to use the tool to add alternate text to figures 
and descriptions to form fields.

The information in this section applies to Acrobat 7.0 Professional. 

 

Where you are in the PDF accessibility workflow 

When to use the TouchUp Reading Order tool
The TouchUp Reading Order tool provides the easiest and quickest way to fix reading order and basic tagging 
problems in Acrobat 7.0 Professional. It helps you achieve the greatest accessibility in the shortest amount of time, 
especially for long documents. 

You use the TouchUp Reading Order tool to perform the following accessibility tasks:

• To visually check, and then repair, the reading order of page content (necessary for screen readers and Reflow view)

• To properly tag fillable form fields and their labels

• To add alternate text to figures and descriptions to form fields (necessary for screen readers)

• To fix the tagging of simple tables, and to prepare complex tables for more advanced manipulation in the tag tree
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Note: Some accessibility tasks—such as fixing complex tables, removing obsolete tags after you delete pages, and adding 
alternate text to links—require that you edit the document’s tag tree. See “Section 13: Fixing advanced 
accessibility problems” on page 92 for instructions.

The TouchUp Reading Order tool is primarily intended for repairing Adobe PDF documents that you tagged by 
using Acrobat, not for repairing PDF documents that you tagged during conversion from an authoring application. 
Whenever possible, you should return to the source file and add accessibility features in the authoring application. 
For example, if you created a tagged PDF document from Microsoft Word, the file probably has acceptable reading 
order. If you intend to add or edit alternate text for the figures, return to the original document in Word, add the 
alternate text, and then resave the file as a tagged PDF document. Repairing the original file ensures that you don’t 
have to repeatedly touch up future iterations of the PDF document in Acrobat Professional. 

How the TouchUp Reading Order tool works
The TouchUp Reading Order tool is on the TouchUp toolbar, and it has its own dialog box of options that enable you 
to control what items display on the page and to apply tags. You use the TouchUp Reading Order tool alongside the 
Order tab of the navigation pane. 

 

The three TouchUp tools on the TouchUp toolbar: the TouchUp Text tool (left), the TouchUp Reading Order tool (center), and the TouchUp 
Object tool (right). To fix reading order and basic tagging problems, you use the TouchUp Reading Order tool (center).

When you select the TouchUp Reading Order tool, the tool’s dialog box opens, and the content on the page is overlaid 
with one or more highlighted regions. Each highlighted region is a shaded, numbered rectangle. Each highlighted 
region on the page has a corresponding numbered entry in the Order tab. The sequence of the numbering indicates 
the reading order of the content on the page. Screen readers and the Reflow view and Read Out Loud feature of 
Acrobat and Adobe Reader all follow this sequence when they present content to a user. 

To open the TouchUp Reading Order dialog box, do one of the following:

• Select Tools > Advanced Editing > Show TouchUp Toolbar, and then select the TouchUp Reading Order tool from 
the TouchUp toolbar. 

• Choose Advanced > Accessibility > TouchUp Reading Order. 

• Choose Tools > Advanced Editing > TouchUp Reading Order Tool. 

To open the Order tab, do one of the following:

• In the TouchUp Reading Order dialog box, click the Show Order Panel button.

• Select View > Navigation Tabs > Order. The Order tab first opens as a floating window. You can dock it to the 
navigation pane by selecting View > Navigation Tabs > Dock All Tabs, or by dragging the Tags tab from the floating 
window to the navigation pane.

• In the navigation pane, select the Order tab (when the tab is docked).
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The numbering of the highlighted regions on a page indicates the reading order of the content. Each highlighted region corresponds to a num-
bered entry in the Order tab. 

How the TouchUp Reading Order tool and the Order tab work together
You adjust the reading order of a page either by manipulating highlighted regions on the page with the TouchUp 
Reading Order tool, or by rearranging, deleting, or adding the corresponding entries in the Order tab. All changes 
that you make on the page are reflected in the Order tab, and vice versa. 

The TouchUp Reading Order tool shows as few highlighted regions as possible on a page. Acrobat Professional 
analyzes where highlighted regions should begin and end based on the TouchUp Reading Order setting that you 
specify in the TouchUp category of the Preferences dialog box. For English documents, this is usually top to bottom, 
left to right. Differing text baselines can cause Acrobat to create many highlighted regions on a page. The number of 
highlighted regions on a page has nothing to do with the complexity or accessibility of the document. Just check two 
things: (1) that the runs of text and figures are properly grouped (or isolated), and (2) that the highlighted regions 
are numbered sequentially in the intended reading order. 
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Some pages show many highlighted regions, but if the reading order is correct, you do not need to change anything. To follow and verify the 
reading order for a cluster of overlapping highlighted regions, as on this page, select entries in the Order tab so that Acrobat highlights each region 
on the page.

How these features interact with the tag tree
No one-to-one relationship exists between the tags in the tag tree and the highlighted regions on the page or the 
entries in the Order tab. The same content that is represented by a highlighted region or entry in the Order tab may 
be represented by many other tags in the tag tree. The TouchUp Reading Order tool “consolidates” groups of these 
tags into highlighted regions so that you can follow and check the reading order more easily. As you use the TouchUp 
Reading Order tool and the Order tab to manipulate highlighted regions, Acrobat Professional does automatically 
add, remove, and rearrange the content’s corresponding tags in the tag tree to match the changes. The converse is 
always not true, however. As you edit the tag tree, the reading order of the highlighted regions and the Order tab may 
not reflect the changes. 

Options for the TouchUp Reading Order tool

Options in the dialog box
The dialog box for the TouchUp Reading Order tool provides the following options:

• Nine tagging buttons. Depending on which tag you apply to a highlighted region, these buttons tag the current 
selection as Text, Figure, Form, Figure/Caption, Heading 1, Heading 2, Heading 3, Table, Cell, Formula, or 
Background. These tags are explained in more detail later in this section.  

• Show Page Content Order. Selecting this option shows page elements as numbered highlighted regions. The 
sequence of numbering indicates the reading order. Click the color swatch at the right of this option to specify the 
color that Acrobat uses for highlighted regions.

• Show Table Cells. Selecting this option shows the content of individual table cells in individual highlighted regions. 
This is useful for detecting rows or columns that are inappropriately merged or split. Click the color swatch at the 
right of this option to specify the color that Acrobat uses to highlight table cells. 
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• Show Tables And Figures. Selecting this option outlines the highlighted region of each table and figure with a 
crossed-out box. Using this feature is a good way to view what the tagging accepted as the boundaries of a table. 
The crossed-out box also displays alternate text (if any) for figures. Click the color swatch at the right of this option 
to specify the color that Acrobat uses to highlight tables and figures.

• Clear Page Structure. Selecting this button removes the tagging structure from all visible pages. If the existing 
structure on a page contains too many problems, use this option to start over and create a new structure for the 
page. 

• Show Order Panel. Selecting this button opens the Order tab in the navigation pane, where you can easily reorder 
the reading order of the highlighted regions. 

These TouchUp Reading Order options are available in four places in Acrobat Professional: in the tool’s dialog box, 
on the Options menu in the Order tab, and on the context menus of the TouchUp Reading Order tool and the 
TouchUp Object tool. 

Note: If highlighted regions don’t appear on the Adobe PDF page when you select Show Page Content Order, the document 
is untagged. You must tag the document before proceeding. See “Section 9: Adding tags to Adobe PDF documents” on 
page 48 for instructions.

 

The TouchUp Reading Order dialog box  A. Tagging buttons  B. Highlighting options  C. Structure display options: Clear Page Structure,  
Show Order Panel  D. TouchUp Reading Order tool 

Additional options on the context menu
Two additional TouchUp Reading Order options are available from the context menu that appears when you right-
click (Windows) or Control-click (Mac OS) a highlighted region while using the TouchUp Reading Order tool or the 
TouchUp Object tool. These options are:

• Edit Alternate Text. This option is available on the context menu for a highlighted figure. Use this option to add 
or edit descriptive text that screen readers can read aloud. 

• Edit Form Field Text. This option is available on the context menu for a fillable form field. Use this option to add 
or edit the descriptions that screen readers can read aloud. 
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TouchUp Reading Order preferences 
The Preferences dialog box (Edit > Preferences) has a TouchUp category that lets you select how Acrobat Professional 
analyzes the content on a page in order to generate the reading order that Acrobat displays when you use the 
TouchUp Reading Order tool. English-language text, for example, typically follows a left-to-right, top-to-bottom 
order. The default setting is Left To Right, Top To Bottom. You can change this setting to accommodate certain types 
of documents or languages. 

The touchup workflow—an orderly approach to repairing reading order 
and tags
The power of the TouchUp Reading Order tool is easy to manage if you approach the touchup process systematically. 

Start by opening the TouchUp Reading Order dialog box, selecting all the options to show content on a page, and 
opening the Order tab. Close the TouchUp Reading Order dialog box, and then go page by page through the 
document, looking at all the highlighted regions for each page. Get a quick feel for the overall reading order of the 
numbered regions. Note any reading order and accessibility problems, such as figures that have been inappropriately 
combined with text, tables that aren’t marked as tables, and figures that are missing alternate text. You may also want 
to have the results of the most recent accessibility Full Check open to guide your inspection and repairs.

Note: The task of repairing tables is discussed later in this section, so you may want to turn off Show Table Cells for now, 
to keep them from interfering with your basic repair work.

Once you’re ready to start repairs, follow these general steps:

Step 1. Fix highlighted regions. Remove nonessential elements (for example, running heads, background graphics, 
and text-as-graphics) from the reading order. Repair improperly grouped text runs, such as captions that are 
separated from their figures and columns that are incorrectly combined. If the document is a form, make sure that 
each form field and its label are combined into their own highlighted region. Be aware that highlighted regions, 
because they are always rectangular, may not precisely cover the content that you want (as in text runs that are L-
shaped, columns that have inset text blocks, or text that runs diagonally). Overlapping highlighted regions do not 
necessarily indicate a reading order problem. 

Step 2. Check the reading order of the remaining highlighted regions. Follow the sequence of numbering to 
verify that the content makes sense when you read the text in the order in which the regions are numbered. Use the 
Order tab to change the reading order as needed.

Step 3. Add alternate text. Add alternate text to figures. If the document is a form, also add descriptive text to the 
form fields.

Step 4. Fix basic table problems. Tasks here include tagging tables that are not identified as tables and tagging cells 
that have been improperly merged or split. 

Step 5. Test as you go. Use Reflow view to check the reading order of more complex pages. Repeat steps 1 through 
4 until the content reads in the proper order. (Fixing some reading order problems may require that you rearrange 
elements in the tag tree by using the techniques in “Section 13: Fixing advanced accessibility problems” on page 92.)

Step 6. Run an accessibility Full Check. Full Check can highlight figures and form fields that still lack alternate text, 
and it may uncover other accessibility problems that you can repair by using the techniques in “Section 12: Adding 
other accessibility features” on page 85.

The rest of this section describes the four basic techniques that you need to know when you use the TouchUp Reading 
Order tool, and shows how to fix common problems that you may encounter in this phase of the Adobe PDF acces-
sibility workflow.
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Four basic techniques you must know to fix reading order problems
Most repairs that you make by using the TouchUp Reading Order tool require that you know how to use the tool and 
the Order tab to do the following four tasks, which are explained below:

• Select highlighted regions 

• Select content on the page

• Apply a new tag to a selection

• Change the reading order (in the Order tab)

The TouchUp Reading Order tool does not include an Undo command, so you may want to save the document (or 
a copy of it) before you use the tool to make drastic changes. To restore the Adobe PDF document to the most 
recently saved state, choose File > Revert.

Always show only one page at a time when you use the TouchUp Reading Order tool (choose View > Page Display > 
Single Page). Any time that you click the Clear Structure button (deliberately or not), Acrobat clears the tags of all 
pages that are visible at the time—even pages that are only partially visible. 

Selecting highlighted regions 
You must be able to select highlighted regions so that you can apply new tags to regions, reorder regions, and remove 
regions from the reading order. You can select highlighted regions on the page or in the Order tab. Selecting them in 
the Order tab can help you locate and select a small or obscured highlighted region on the page. You may want to 
zoom in to higher magnifications to select a specific region from among many in the page. 

To select a highlighted region on the page:

1  Select the TouchUp Reading Order tool.

2  In the document pane, click the number that is in the upper left corner of a highlighted region (the cursor becomes 
a hand). If the Order tab is open, Acrobat highlights the corresponding entry in the tab.

3  To select multiple regions at once on the page, press Shift, Ctrl (Windows), or Command (Mac OS) as you click 
the numbers of the highlighted regions.

 

A highlighted region that has been selected by using the TouchUp Reading Order tool
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To select a highlighted region in the Order tab:

1  Open the Order tab. 

2  In the Order tab, click the plus sign (+) of the entry that represents the page that contains the highlighted regions 
that you want to view. 

3  Select a numbered entry in the list. Each numbered entry represents a highlighted region; the number of the region 
is in brackets ([  ]). Acrobat highlights the region on the page.

4  To select multiple highlighted regions at once, press Shift, Ctrl (Windows), or Command (Mac OS) as you click 
the entries.

 

Multiple highlighted regions that have been selected in the Order tab

Selecting content on the page
You must know how to use the TouchUp Reading Order tool to select text and figures on the page so that you can 
define new highlighted regions to fix the reading order, apply tags (for example, Figure, Table, Form Field, or 
Background) to content, and add alternate text to figures or descriptions to form fields. You can use keystrokes to 
add content to, or subtract content from, a current selection. You may want to zoom in to higher magnifications as 
you work.

To select content on the page:

1  Select the TouchUp Reading Order tool and open the Order tab.

2  In the document pane, do the following:

• To select content, drag the cursor.

• To add content to the current selection, Shift-click and drag the cursor to select the content that you want to add. 
(The cross-hair pointer changes to include a plus sign.)
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• To remove content from the current selection, Ctrl-click (Windows) or Command-click (Mac OS) and drag the 
cursor to select the content that you want to remove. (The cross-hair pointer changes to include a minus sign.)

Using the TouchUp Reading Order tool to select page content (upper right). Removing text from the selection (lower left). Adding text to the  
selection (lower right).

Applying a new tag to a selection
Knowing how to change the tag of a selected highlighted region, text, or object enables you to repair many types of 
reading order problems. The TouchUp Reading Order tool enables you to apply the following nine types of tags:

• Text. Tags the current selection as text. 

• Figure. Tags the current selection as a figure. Screen readers will not read any text that is defined as part of a figure, 
including text that is inadvertently attached to the figure. Figures require alternate text. 

• Figure/Caption. Tags a selected figure and caption by using a single tag. Any text blocks that are in the selection 
(including labels that are meant to be part of the figure) are defined as a caption and may be read by a screen reader. 
This tag type is useful for tagging photos with their captions and preventing the caption text from being incorrectly 
added to adjacent text blocks. Figures require alternate text. 

• Form Field. Tags the current selection as a form field. Use this option to group text labels and form fields in the 
correct order based on the reading direction of the language. The form field itself is tagged as a field, and any 
surrounding text is tagged as the label of the form field.

• Heading 1, Heading 2, Heading 3. Tags the current selection as a first-, second-, or third-level heading. You can 
create bookmarks based on the heading tags to help users navigate the document. 

• Table. Instructs Acrobat to analyze the selection to determine the location of headings, columns, and rows, and 
then to tag the selection as a table. The results may or may not accurately reflect the table structure; complex tables 
may require that you edit the tag tree. 

• Cell. Tags the current selection as a table or header cell. Use this tag to merge cells that are incorrectly split, or to 
split cells that are incorrectly merged. The results may or may not accurately reflect the table structure, and you 
may need to edit the tag tree to correctly tag cells that span columns or rows.

• Formula. Tags the current selection as a formula. 

• Background. Tags the current selection as a background element (artifact), which removes the item from the tag 
tree so that screen readers don’t read it and Reflow view doesn’t display it. 
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To apply a new tag to a highlighted region or selected content: 

1  Select the TouchUp Reading Order tool and open the Order tab.

2  On the page or in the Order tab, select the highlighted region or select content.

3  Do one of the following:

• In the TouchUp Reading Order dialog box, click a tag button.

• In the Order tab, open the Options menu and select a tag. (Tip: Press the Delete key to apply the Background tag.)

• Open the context menu of the TouchUp Reading Order tool (right-click in Windows, Control-click in Mac OS), 
and select a tag.

Note: When you retag content, Acrobat reorders the highlighted regions. If the newly tagged content both has the same 
tag and naturally follows the reading order of a highlighted region that is directly adjacent to, or surrounding, the original 
highlighted region, Acrobat combines the two regions into one. 

Changing the reading order (in the Order tab)
Dragging highlighted regions around in the Order tab is the fastest way to change the reading order of a page’s 
content.

To change the reading order in the Order tab:

1  Select the TouchUp Reading Order tool, and open the Order tab. 

2  On the page or in the Order tab, select a highlighted region.

3  In the Order tab, select the entry that you want to move, and drag it to the location that you want. As you drag, a 
line appears showing potential locations. A barred circle icon indicates places where the tag cannot be moved. 

4  Release the mouse at the desired target location, and Acrobat renumbers the reading order in the Order tab and 
on the page.

Note: You can also cut and paste entries in the Order tab.

 

Drag entries in the Order tab (left) to change the reading order of the content (right).
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Fixing common problems 
All instructions in this section presume that you have selected the appropriate highlighting options in the TouchUp 
Reading Order dialog box, so that you can view the highlighted regions of the content that you are manipulating. 
These options are Show Page Content Order, Show Table Cells, and Show Tables And Figures. 

To maximize your onscreen workspace, you may want to close the TouchUp Reading Order dialog box after selecting 
the highlighting options, and use only the Order tab to change reading order and apply tags. Each time that you open 
the Order tab, Acrobat displays the types of highlighted regions that are currently active.

Fixing highlighted regions
This section describes how to recognize and fix common problems with highlighted regions, such as nonessential 
content that should be removed from the reading order, captions that are separated from their figures, and 
highlighted regions that inappropriately group text.

EXAMPLE 1. Removing nonessential content from the reading order
Ideally, only text and figures that are meaningful to the document’s content should be tagged for reading by screen 
readers. In this example, the page has many elements that add visual interest to the page but are not mandatory for 
people to read. To simplify comprehension for the page, apply the Background tag to all nonessential art and text to 
remove it from the reading order.

Problem: Nonessential content has been tagged as a figure or text (upper left). Solution: Select the highlighted regions (upper right), and tag 
them as Background (lower left). With all nonessential content tagged as Background, the finished page has only three highlighted regions for a 
screen reader to vocalize (lower right).
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Note: Although you can select multiple highlighted regions and tag them all at once as Background, doing so may cause 
Acrobat to send the tagged content to the beginning of the drawing order in the page, so that other objects may cover them 
when Acrobat redraws the screen. If items that you want to set as Background are on top of graphical elements in the page 
design, you may need to select and tag each Background item one by one, rather than tag them all at once. This technique 
ensures that Acrobat retains the objects in the proper drawing order on the page and that the page redraws correctly.

EXAMPLE 2. Recombining captions with their figures
Captions sometimes get separated from their figures when you tag a file from within Acrobat. In this sample page, 
the caption text became part of Highlighted Region 3 instead of being included with its artwork. The easiest way to 
recombine these elements is to select both the caption and the figure, and then apply the Figure/Caption tag. 

Problem: Caption text is separated from its figure (upper left). Solution: Select the caption and figure (upper right), and tag it as Figure/Caption 
(lower left). Result (lower right). 
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EXAMPLE 3. Tagging incompletely tagged figures
Tagging in Acrobat occasionally separates figures and the text elements that they contain into more than one 
highlighted region. This may happen, for instance, when a figure contains many text labels, as in the example below, 
where the A, B, and C labels have been tagged as text instead of as part of the art. To fix this reading order problem, 
select all the elements that belong to the figure, and then apply the Figure tag.

Problem: All parts of a figure aren’t included in the highlighted region for the figure (upper left). Solution: Select all of the figure content  
(upper right), and tag it as Figure (lower left). Result (lower right). 
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EXAMPLE 4. Fixing improperly grouped columns 
When you tag multicolumn files by using the Add Tags To Document command, Acrobat sometimes combines all 
the columns into one highlighted region. Screen readers cannot read side-by-side columns as discrete columns of 
text unless you give each column its own place in the reading order. To do this, select and tag the columns individ-
ually as Text—in this case, you tag one column, and Acrobat splits the region into two columns.

In rare situations, columns may be too close together for Acrobat to treat as separate highlighted regions, even if you 
use the TouchUp Reading Order tool to select and tag them separately. You may need to leave the columns in one 
highlighted region and use the document’s tag tree to verify (and edit, if needed) the reading order of the columns. 
See “Section 13: Fixing advanced accessibility problems” on page 92.

Problem: A single highlighted region contains two columns of text (upper left). Solution: Select one of the columns (upper right), and tag it as 
Text (lower left). Result (lower right). 
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EXAMPLE 5. Fixing improperly grouped columns of varying widths
Some layouts use a variety of column widths that add visual interest to the page, but that can be challenging for the 
tagging process to interpret. In this example, Acrobat combined one wide column and two narrow columns into one 
highlighted region. As in Example 4, you only need to select and tag one of the side-by-side columns as Text to fix 
this problem. 

Although the final highlighted regions overlap, the resulting reading order is correct (presuming at top-to-bottom, 
left-to-right reading order). A screen reader will start from Highlighted Region 1, read the topmost, wider column 
first, and then read the left-hand column beneath it. It will then go to Highlighted Region 2 to read the right-hand 
column. You can double-check the reading order for complex content like this by using the tag tree, as described in 
“Section 13: Fixing advanced accessibility problems” on page 92.

Problem: A single highlighted region contains multiple columns of text that have different widths. Solution: Select one of the narrower columns 
(upper right), and tag it as Text (lower left). Result (lower right). 
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EXAMPLE 6. Tagging and fixing form fields and text labels
PDF forms often contain text labels for their form fields. Tagging the form after you add fillable form fields generally 
produces correct tags for the form fields. Sometimes, however, the tagging process may incorrectly merge or split the 
text labels for the fields, or it may separate the form field from its text label. To fix this problem, use the TouchUp 
Reading Order tool to select both the field and its text label and then apply the Form Field tag. Repeat this procedure 
for each form field.

In this complex form, you would also need to correct the reading order after you complete the tagging, so that the 
fields read across the page correctly. See Examples 7 and 8 for instructions.

Problem: Field labels in a form have been incorrectly merged and form fields are not tagged as part of the reading order (upper left).  
Solution: Select the first fillable field and its text label (upper right), and tag them as Form Field (center left). The result is a separate numbered 
region for each component (center right). Repeat across the row (lower left). After you have tagged all of the fields and text labels (lower right), 
you must check the proper reading order of all of the form’s components and fix the reading order as needed.
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Fixing reading order problems
You can fix the reading order of highlighted regions by rearranging the order of entries in the Order tab or by 
dragging the highlighted region on the page in the document pane. Using the Order tab is the easiest way to fix a 
page’s reading order. For instance, if one highlighted region of text comes too late, you drag the name of the region 
into its proper, earlier place in the Order tab. On the page, the highlighted regions renumber to follow the new 
reading order. This section illustrates two examples of fixing reading order by using the Order tab.

EXAMPLE 7. Fixing the reading order on a simple page 
In this sample page, the “Feature Story” heading and author’s byline are number 3 in the reading order, instead of 
being number 1 and preceding the first paragraph of the story. To bring this text to the top of the reading order, drag 
its numbered entry into the topmost position in the Order tab. 

For greater accessibility on this page, you would also tag the running header and page number (highlighted regions 
4 and 5) as Background to remove them from the reading order.

Also note that although the highlighted region that surrounds the body of the story contains two columns of text, 
the reading order for this text is correct and does not need repair. The columns are not side by side, and a screen 
reader would read this text from top to bottom, left to right, and present this content correctly to the user.  

Problem: Content isn’t in the proper reading order (upper left). Solution: Select the entry in the Order tab that corresponds to the content that 
you want to reorder (in this case, region number 3), and then drag it into the number 1 position for the reading order (upper right). Corrected 
reading order (bottom).
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EXAMPLE 8. Fixing the reading order on a complex page
Here is an example of the types of reading order problems that can occur when Acrobat must interpret and tag a very 
complex layout. On this Q&A page, the reading order starts in the lower right column, jumps to the lower left 
column, goes to the question in the circle, and then returns to the first column. A better reading order would send 
the reader through the first column, then to the question in the circle, which is answered in both the second and third 
columns, and then finally to the sidebar of text that is at the top of the third column.

Keep in mind that each time you adjust the reading order, Acrobat recalculates all of the regions on the page and 
renumbers them as appropriate. Although this page has several places where the reading order is incorrect, fixing it 
requires only three rearrangements in the Order tab, as illustrated below.

Problem: Content isn’t in the proper reading order. The solution is described on the next two pages.
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Solution: Start at the left column on the page. In the Order tab, move the entry for region number 4 into the number 1 position in the reading 
order (top). After Acrobat adjusts the reading order, the second portion of that column ends up in the number 3 position (middle), so drag the 
entry for region number 3 into the number 2 position in the Order tab (bottom). The solution is continued on the next page.
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Solution, continued. After Acrobat adjusts the reading order, the left column is in the correct reading order, but regions number 4 and 3 are not 
in the correct order (top). To fix this problem in one step, drag the entry for region 3 into the number 6 position in Order tab (middle). The 
corrected reading order (bottom).
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EXAMPLE 9. Changing the reading order to make a figure follow its reference
A second way to change the reading order is to drag highlighted regions on the page. This technique is most useful 
when you want to make a screen reader read a figure and caption at the specific point where they are referenced in 
the text. When you drag a highlighted region on a page, a text-insertion pointer follows the mouse to show you the 
exact drop location. If that location is inside another region, Acrobat splits that region to insert the dragged region 
into the reading order at that location, and then renumbers all highlighted regions to show the new reading order. 
With this technique, you are in essence “moving” figures in the reading order to follow their in-text references. 
Remember that this technique changes only the reading order. No content on the page changes appearance. 

Problem: You would like a figure and its caption to be near where they are discussed in the reading order (upper left). Solution: Click the number 
of the highlighted region (upper right) and drag the mouse to place the text-insertion pointer at the target location (lower left). The result (lower 
right) splits the target region into two regions and creates a new entry for each region in the Order tab.
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Adding alternate text to figures and descriptions to form fields
Alternate text and descriptions provide more information about figures and form fields for people who can’t visually 
interpret the page. Figures that can have alternate text include images, graphics, charts, and illustrations. 

Note: You can also add alternate text to links by editing the tag tree. See “Section 13: Fixing advanced 
accessibility problems” on page 92.

EXAMPLE 10. Adding alternate text to figures
Alternate text is meant to provide meaningful descriptions of graphical elements that illustrate important concepts 
in the document. A screen reader cannot recognize figures unless you add alternate text. When you select Show 
Tables And Figures in the TouchUp Reading Order dialog box, Acrobat indicates whether alternate text exists for 
figures. If alternate text exists, Acrobat displays the first few words of the text as part of the highlighted region for the 
figure. To add or edit alternate text, select the figure and choose Edit Alternate Text from the context menu.

Note: You can also add alternate text to figures by using the TouchUp Object tool. Select a figure with the tool, open the 
tool’s context menu, select Properties, and then type the alternate text in the Tag tab.

Problem: Figure lacks alternate text (upper left). Solution: Use the TouchUp Reading Order tool to select the figure, open the context menu, and 
then choose Edit Alternate Text (upper right). In the Edit Alternate Text dialog box, type a description for the figure (lower left). Acrobat displays 
the first words for the figure in its highlighted region (lower right).
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EXAMPLE 11. Adding descriptions to form fields
You can add a description to a form field as you create the form field by typing the text in the Tooltip box of the field’s 
Properties dialog box, as described in “Section 8: Making Adobe PDF forms accessible” on page 39. If you did not 
add a description at that time, you can add it in this step of the workflow by using the Edit Form Field Text command 
that is on the context menu of the TouchUp Reading Order tool. 

A description enables screen readers to identify the form field to users. Users hear the description read aloud when 
they tab to the field. Write descriptions that are terse but complete. For example, for a first-name field, type a 
description that is something like “First name.” Descriptions should not contain instructions such as “Enter . . . .” 

Note: Do not edit the tag tree to add alternate text (which is different from a description) to a Form tag; doing so is a 
serious accessibility error, for screen readers never find out about the form field. 

Problem: A form field needs a description (upper left). Solution: Use the TouchUp Reading Order tool to select the field, open the context menu, 
and then choose Edit Form Field Text (upper right). In the Form Field Text dialog box, type a description for the form field (lower left).When 
you place the Hand tool or the Select tool over the field, Acrobat displays the description that a screen reader will use (lower right).
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Fixing basic table problems
Tables pose a special challenge for accessibility because content in a table is meant to be read both across and down. 
However, screen readers, by their very nature, can only present information sequentially. For this reason, it is 
especially important that you correctly tag tables. 

Acrobat may have trouble correctly recognizing and tagging complex tables. Use the TouchUp Reading Order tool to 
correct basic problems such as tables that have not been recognized as tables, and multiple cells that have been tagged 
as one cell. To resolve complex tagging issues for tables, you must edit the tag tree. See “Section 13: Fixing advanced 
accessibility problems” on page 92. 

To view tables and cells, select the Show Figures And Tables and the Show Table Cells options in the TouchUp 
Reading Order dialog box. When you examine the highlighted regions of the cells for problem areas, do one of the 
following:

• If two or more cells are incorrectly merged, use the TouchUp Reading Order tool to select the content that is meant 
to be within a single cell, and then tag it as Cell. Repeat for each merged cell. 

• If a cell has been incorrectly split into separate cells, merge them by selecting all relevant content, and then tagging 
it as Cell. You will need to edit the tag tree to set ColSpan and RowSpan attributes for these cells. 

• If no cells are highlighted, select individual cell content, and then tag it as Cell. Repeat for all table content. You will 
need to edit the tag tree to complete the table corrections. 

Note: Acrobat may not correctly interpret changes that you make at the cell level of a table. You will need to edit the tag 
tree to finish making the table accessible. 

EXAMPLE 12. Correcting an incorrectly tagged table
This sample table uses shading to mark its rows and boundaries, which can cause problems when Acrobat tags a 
document. The tagging function interpreted the shading as graphics and interpreted the table text as Text elements 
instead of as table cells. To fix this problem, select all of the table content and tag it as Table. You can then turn on 
Show Table Cells in the TouchUp Reading Order dialog box to verify whether the cells are discrete units. 

    

Problem: An artistically designed table (top) hasn’t been identified as a table (bottom). The solution is described on the next page.
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Solution: Select all the content in the table (top) and tag it as Table (second row). This tags the entire table (third row), which you can then 
check for the accuracy of its cell tagging (bottom).
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Starting over on a page
Adding tags to an Adobe PDF document in Acrobat sometimes results in a tagging structure that is overly compli-
cated or too problematic to fix. In this case, you can use the TouchUp Reading Order tool to remove or replace the 
current structure for a page, and then create highlighted regions that reflect a simpler structure. This technique 
deletes the tags from the page and inserts new tags as you work with the TouchUp Reading Order tool. 

Starting over on a page works most successfully if the document contains mostly text. Using the TouchUp Reading 
Order tool creates very basic tagging, because you have only nine tag types available. To have greater control over a 
broader hierarchy, such as section-level tags, you must edit the tag tree. Before you clear the existing structure, make 
sure that this option is your only recourse. 

Important: Be sure that you are viewing the document in Single Page view before you clear the structure of a page. 
Whenever you use the Clear Structure button, Acrobat clears the tags of all pages that are visible—even pages that are 
only partially displayed. The TouchUp Reading Order tool also has no Undo function, so you may want to save a copy of 
the document before using the Clear Structure feature.

To start over on a page: 

1  Set the page display to Single Page (View > Page Layout > Single Page).

2  Select the TouchUp Reading Order tool.

3  In the TouchUp Reading Order dialog box, click Clear Structure. 

4  In the document pane, drag to select the content for the first page element that you want to tag (for example, 
Heading 1), and then apply the appropriate tag. 

5  Repeat for each page element on the page until all the content is tagged.

Finishing the Adobe PDF document for accessibility
Remember that fixing the reading order is only part of the Adobe PDF accessibility workflow. You should also 
perform the following steps in Acrobat Professional to ensure the accessibility of the PDF document: 

1  Add other features to optimize the PDF document for accessibility. See “Section 12: Adding other accessibility 
features” on page 85. 

2  Edit the tag tree to repair complex problems. See “Section 13: Fixing advanced accessibility problems” on page 92.
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Section 12: Adding other accessibility 
features

This section describes how to add other accessibility features to an Adobe PDF document, including accessible links 
and document navigation features. It also describes how to set a document language, set security settings so they 
don’t interfere with assistive technology, and add a watermark to tagged PDF documents.

The information in this section applies to both Acrobat 7.0 Professional and Acrobat 7.0 Standard unless otherwise 
noted.

 

Where you are in the PDF accessibility workflow 

Other accessibility features in Acrobat
This section presumes that you are working from a tagged Adobe PDF document that you have checked for reading 
order and that contains alternate text for figures and descriptions for form fields. The techniques in this section will 
help you achieve optimal accessibility by using the other standard accessibility features in Acrobat. For advanced 
problems, you need to edit the document’s tag tree in Acrobat Professional. See “Section 13: Fixing advanced 
accessibility problems” on page 92. 
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This section describes how to apply the following accessibility features:

• Setting tab order

• Adding bookmarks

• Adding accessible links

• Establishing a document language

• Setting security settings so they don’t interfere with screen readers

• Adding a watermark to a PDF document

Setting the tab order 
Having a preset tab order enables people with disabilities to use a keyboard to move among actionable items in an 
Adobe PDF document in a logical order. Tab order applies to embedded links and URLs, form fields, and comments. 
In accessible PDF documents, you should set the tab order to use the document’s structure, which builds the tab 
order from the tag tree and ensures a sequential path through a page. (If the PDF document has form fields, you 
should have already done this step as part of the workflow, as described in “Section 8: Making Adobe PDF forms 
accessible” on page 39.)

To set the tab order to the document’s structure:

1  Open the Pages tab of the navigation pane. 

2  Select all the pages by pressing Ctrl+A (Windows) or Command+A (Mac OS).

3  In the Pages tab, choose Options > Page Properties. 

4  In the Page Properties dialog box, select the Tab Order tab, and then select Use Document Structure.

Adding bookmarks
Bookmarks enable people to navigate a document without paging through it. You often have the option to add 
bookmarks to an Adobe PDF document during conversion to PDF from an authoring application. You can also add 
bookmarks in Acrobat, either automatically from the structure of a tagged PDF document, or one at a time from 
selected text.

To create bookmarks automatically from the structure, open the Bookmarks tab in the navigation pane, and then 
choose Options > New Bookmarks From Structure. 

To create bookmarks one at a time, use the Select tool to select the text on the page that you would like to use as the 
bookmark, and then choose Options > New Bookmark from the Bookmark tab. You can also nest bookmarks in the 
Bookmarks tab to reflect the hierarchy of information in the document. 

Using a highly visible color and different type styles to denote top-level bookmarks further eases navigation for 
visually impaired users. You can change the color and other properties of bookmarks by using the Bookmarks 
Properties dialog box. 

For instructions on using bookmarks, see “Adding navigability to Adobe PDF documents” in Acrobat 7.0 Help.  
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Choosing New Bookmarks From Structure in the Options menu of the Bookmarks tab to create a set of bookmarks that is based on the tag tree

  

Setting bookmark appearance in the Bookmarks Properties dialog box (left); the bookmarks after they have been formatted for greater visibility (right).

Adding accessible links
Links can enable readers to quickly move from one part of a document to another, to related information in a 
different document, or to a website that is relevant to the content. Links enhance accessibility by providing direct 
jumps to new locations, thereby reducing the need for users to manually switch documents or search for a specific 
reference point. 

Depending on how you tagged the document and incorporated links, you may or may not need to add links at  
this stage:

• If you tagged the Adobe PDF document during conversion from an authoring application, the links and URLs in 
the document are probably already active and have been correctly included in the tag tree so that they are accessible 
to screen readers. You do not need to do this step in the workflow unless you would like to add more links, such as 
to convert the entries in a table of contents to hyperlinks. 

• If you tagged the PDF document in Acrobat according to the instructions in “Section 9: Adding tags to Adobe PDF 
documents” on page 48, you should have first applied the Create From URLs In Document command to activate 
the web links and prepare them for proper tagging in Acrobat. Because Acrobat may not correctly recognize URLs 
that end in a slash (such as www.adobe.com/support/), however, you may need to activate these URLs manually by 
using the method described in this section. You may also want to create other types of links at this stage of the 
workflow.
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• If you are working from a tagged PDF document whose links and URLs are not yet active, follow the instructions 
in this section to make them active and to add them to the tag tree. 

After all the links are complete, you may also want to edit the tag tree to add alternate text to the links, to improve 
the user’s experience. 

Acrobat provides several ways to create active links for text, objects, and URLs in a PDF document. However, because 
the methods differ in how they affect the tag tree, Adobe recommends only one method at this stage in the workflow: 
activating each link manually by using the Create Link command. 

Unlike the other methods for creating links in a tagged PDF document (by using the Links tool or the Create From 
URLs In Document command), using the Create Link command adds all three tags that screen readers require in 
order to recognize a link. The other methods create only one of the three tags, which means that you must manually 
edit the tag tree to add the remaining two tags for each link and place these tags in the proper reading order in the 
tree. Although you must activate links one by one, using the Create Link command provides the fastest results and 
the least amount of follow-up work to make the links accessible to screen readers. All that you need to do afterward 
is edit the tag tree to add alternate text to the new links, if desired.

You must use Acrobat Professional to perform this accessibility task, and to add alternate text to links. Creating links 
by using Acrobat Standard does not generate any tags for the links. 

Note: If you have already used the Links tool or the Create From URLs In Document command on a tagged PDF 
document, see “Section 13: Fixing advanced accessibility problems” on page 92 for instructions on creating the proper set 
of tags for these links.

Creating a link by using the Create Link command
To simultaneously activate a link and add its tags to the tag tree, use the Select tool or the Snapshot tool to select 
content on the page (such as text, a URL, or an object), open the context menu, and then choose Create Link. Define 
the attributes for the link in the Create Link From Selection dialog box. When you create a link from text, the content 
of the text that you select is used as the link’s text. See “Adding navigability to Adobe PDF documents” in Acrobat 7.0 
Help for more information.

 

The Create Link From Selection dialog box, where you define the type of link that you want to create from the selected content

Adding alternate text to links 
You can edit the tag tree to add alternate text descriptions to links. Alternate text is useful for clarifying the purpose 
or the use of the link for users who have screen readers. 
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For instance, you can have a screen reader tell a user to go to “the Acrobat accessibility page of adobe.com” rather 
than go to “http://www.adobe.com/products/acrobat/solutionsacc.html.” 

For instructions on how to add alternate text to links in the tag tree, see “Section 13: Fixing advanced 
accessibility problems” on page 92.

Setting the document language
Setting a language for an Adobe PDF document improves its readability and accessibility by providing more infor-
mation about the document to a screen reader. You set the language for an entire document in the Advanced tab of 
the Document Properties dialog box (File > Document Properties) in Acrobat Professional or Acrobat Standard.

 

Setting the language for an entire document

Acrobat includes 16 preset language selections. If you need to specify a language that is not on the list, such as 
Russian, you must type the ISO 639 code for the language, not its name. You can find the ISO 639 codes at 
www.loc.gov/standards/iso639-2/langhome.html.

If the PDF document uses more than one language, you can edit the tag tree in Acrobat Professional to give individual 
sections, paragraphs, or words their own language setting. See “Section 13: Fixing advanced accessibility problems” 
on page 92.

Note: When an accessibility Full Check reports that you have not specified a document language in one or more places, 
use this technique to set the default language for all parts of the document at once.

www.loc.gov/standards/iso639-2/langhome.html
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Setting security settings so they don’t interfere with screen readers 
In the Security tab of the Document Properties dialog box, you can choose a security method to specify that no part 
of the accessible Adobe PDF document is to be copied, printed, extracted, commented on, or edited. However, the 
security setting that restricts copying can interfere with a screen reader’s ability to read the document, since reading 
the text depends on a sort of copying in order to play it back. 

To keep PDF documents accessible, Acrobat provides an option that is useful for people who use screen readers: 
Enable Text Access For Screen Reader Devices For The Visually Impaired. This option overrides the document’s 
security settings only for the purpose of giving assistive technology, such as screen readers, access to the content. This 
option is on by default in the Password Security Settings dialog box. If you intend to make other changes to security 
settings, be sure that this option remains selected once it becomes active as you change security settings.

For more information on security and the security options, see “Adding security to Adobe PDF documents” in 
Acrobat 7.0 Help.

 

The Password Security Settings dialog box, where you can enable screen readers to access a document while retaining other security settings

Adding a watermark to an Adobe PDF document
You can add watermarks to Adobe PDF documents in a way that inserts the watermark into the tagged PDF 
document without also adding it to the tag tree. Not having the watermark appear in the tag tree is helpful for people 
who are using screen readers, because they won’t hear the watermark read as document content. 

The best way to add a watermark is to insert an untagged PDF document of the watermark into a tagged PDF 
document. For more information about using the Watermark & Background feature, see “Adding watermarks and 
backgrounds” in Acrobat 7.0 Help.
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Finishing the Adobe PDF accessibility workflow
Congratulations! You’ve made it through all the steps necessary to make most Adobe PDF documents accessible to 
people with disabilities. 

Before distributing the document, test the file for accessibility one last time. Run an accessibility Full Check, open 
the document using a screen reader, or use one of Acrobat’s features to verify the reading order, as described in 
“Section 10: Evaluating Adobe PDF documents for accessibility problems” on page 52. 

If the final test still shows problems with reading order or basic accessibility, return to the appropriate sections of this 
guide and use the TouchUp Reading Order tool and other features in Acrobat Professional to fix them.

Going the extra mile for accessibility
Acrobat Professional provides access to an Adobe PDF document’s tag tree, which you can edit to achieve optimal 
accessibility for people with disabilities. Some of the techniques of editing the tag tree are very basic, and some are 
quite advanced. You should consider editing the tag tree if you want to do any of the following tasks to optimize the 
accessibility of a PDF document:

• Create tags for links that you added to a tagged PDF document by using the Links tool or the Create From URLs 
In Document command 

• Add alternate text to links

• Rearrange groups of tags to match the order of pages that you replaced or inserted into the PDF document

• Remove obsolete tags that are left over after you deleted pages from the document

• Add expanded text to acronyms and abbreviations

• Set the document language for specific paragraphs or text

• Make tables fully accessible

• Check and fix the logical reading order of complex pages

For instructions on how to perform any of these tasks in the tag tree, see “Section 13: Fixing advanced 
accessibility problems” on page 92. 
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Section 13: Fixing advanced 
accessibility problems

This section is for advanced users who need to edit the tag tree of an Adobe PDF document to add specific accessi-
bility features or to fix complex accessibility problems. You can edit the tag tree to create tags for links that you added 
late in the workflow, add alternate text to links, improve the accessibility of complex tables, remove obsolete tags, 
rearrange the tags of entire pages at a time, and perform other detailed changes on tags. 

The information in this section applies to Acrobat 7.0 Professional. 

Note: As appropriate, this section directs you to Acrobat 7.0 Help for basic information about working with tags, and it 
offers additional instruction and tips that are relevant to using the tag tree to make PDF documents more accessible. 
However, an in-depth discussion of tagging is beyond the scope of this document. For more information on logical 
document structures, expert users can refer to the PDF Reference, Fifth Edition, on the Adobe website at 
http://partners.adobe.com/links/acrobat. 

 

Where you are in the PDF accessibility workflow 

www.loc.gov/standards/iso639-2/langhome.html
www.loc.gov/standards/iso639-2/langhome.html
www.loc.gov/standards/iso639-2/langhome.html
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When to use the techniques in this section
Whenever possible, you should adjust a document’s reading order by using the TouchUp Reading Order tool instead 
of the tag tree. The TouchUp Reading Order tool is easier to use than the tag tree, and the corrections you make by 
using the TouchUp Reading Order tool optimize the document for both assistive technology and Reflow view. Reflow 
view does not read the tag tree, so changing the order of tags in the tag tree does not affect the presentation of infor-
mation in Reflow view. The tag tree affects only the presentation of information to assistive technology. 

You should, however, edit the Adobe PDF document’s tag tree any time that you want to achieve optimal accessibility 
for people with disabilities. Some of the techniques of editing the tag tree are very basic, and some are quite advanced. 
You should consider editing the tag tree if you want to do any of the following tasks to optimize the accessibility of a 
PDF document:

• Find a tag and its corresponding content (knowing this basic technique speeds up work in the tag tree)

• Create tags for links that you added by using the Links tool or the Create From URLs In Document command on 
a tagged PDF document

• Add alternate text to links

• Rearrange tags to match the order of pages that you replaced or inserted into the PDF document

• Delete tags that are left over after you replaced or deleted pages from the document

• Create new tags (for example, to add higher level section tags)

• Add expanded text to acronyms and abbreviations (so that screen readers can read the full phrases to the user)

• Set the language for specific paragraphs or text

• Make tables fully accessible

• Check and fix the reading order of complex pages

This section of the guide describes how to do each of these tasks. All of these tasks require Acrobat Professional.

Note: If possible, use a screen reader to test the changes that you make to the tag tree. If you don’t have a screen reader, 
use the operating system’s screen reader (if one is available), or follow the instructions under “Checking and fixing the 
reading order of complex pages” on page 104 to go line by line down the tag tree to check the reading order of a page.

How to read an Adobe PDF document’s tag tree
Tagging an Adobe PDF document establishes a relationship between the elements on the pages (the page elements) 
and a reading order (the logical structure) that assistive technology uses to present those elements to a user. This 
relationship is reflected in the document’s hierarchical tag tree, which is also known as the logical document structure.

The tag tree hierarchy
The tag tree is in the Tags tab of the navigation pane. (You can also view the Tags tab as a floating window.) In the 
tag tree, you can expand and collapse groups of tags, drag and rearrange tags, copy and paste tags, and delete tags. 
To show all the tags, Ctrl+click (Windows) or Option+click (Mac OS) on the plus sign of the topmost tag (the  
root tag).
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The tag tree of a PDF document has child and parent elements. Here the Tags tab is docked in the navigation pane. The Tags tab can also be a 
floating window.

Tags in an Adobe PDF document are similar to the markup in HTML, in that both types of tags define the hierarchy 
of information. In a PDF tag tree, you see elements such as <H1> tags to indicate first-level headings, <P> tags to 
indicate paragraphs, and <Table> tags to indicate tables. Tags correspond to text, images, form fields, annotations, 
and links.

The tag tree is organized in a hierarchical structure. The topmost tag, called Tags, is the root tag. Any tag that has tags 
that are indented beneath it is called a parent tag. The tags that are indented beneath a parent tag are called child tags. 

The root tag is a parent tag, and the tags below it are all child tags. The root tag remains the common ancestor for all 
tags, but subsequent tags can have child tags of their own to reflect specific relationships among the tags and the page 
elements that they represent. For example, a list (<L>) tag may be the parent to a list of several list item (<LI>) tags. 
Similarly, a division (<Div>) tag may be the parent of one or more section (<Sect>) tags.

In the tag tree, an icon of a paper tag indicates an object tag, and an icon of three little boxes indicates a document 
content tag. A document content tag identifies the specific element of content (such as text, a bullet, a URL, or a 
graphic) that corresponds to that tag. The tag tree displays the first few words of the content that it represents,  
or a description (if available) of nontext content, to help you keep track of tags. Document content tags are never 
parent tags. 

Assistive technology reads the tags of a tag tree in order down the tree. At the page level, the tags for the individual 
page elements must be in a logical reading order. At the document level, the group of tags for each page must be in 
the same order as the pages themselves.

Note: Each element of content in a PDF document can be tagged, but it doesn’t have to be. If an element is not tagged, 
screen readers do not recognize that it is there, so they do not read it to the user.
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For instructions on how to navigate and select items in the tag tree, see “Advanced tools for correcting tagging errors” 
in Acrobat 7.0 Help. For a list of standard tag types that apply to Adobe PDF documents, see “Appendix: Standard 
tags for Adobe PDF documents” on page 106.

Finding a tag and its corresponding content 
This section describes the two most important techniques that you need to know to speed up your work with the tag 
tree: how to find the content that corresponds to a tag that you select in the tag tree, and how to find the tag that 
corresponds to the content that you select on a page. 

To find the content that corresponds to a tag that you select in the tag tree: 

1  Open the Tags tab in the navigation pane.

2  Select the tag whose content you want to find.

3  On the Tags tab, choose Options > Highlight Content. A bounding box in the document highlights the content 
that is associated with the selected tag.

 

Selecting the Highlight Content command (left), so that Acrobat displays a box around the content on a page that corresponds to a selected  
tag (right)

To find the tag that corresponds to content that you select on a page: 

1  Use the Select tool, the TouchUp Text tool, or the TouchUp Object tool to select content (text or a figure) on the 
page. The last two tools are on the TouchUp toolbar (Tools > Advanced Editing > Show TouchUp Toolbar).

Note: If you are selecting a link, select a range of text that is near the link, or start the selection a few characters on either 
side of the link. Ideally, you would select the link itself, but doing so activates the link.

2  Open the Tags tab in the navigation pane.

3  On the Tags tab, choose Options > Find Tag From Selection. Acrobat highlights the tag that is associated with the 
selected content. 
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Selecting the Find Tag From Selection command (left), so that Acrobat highlights the tag that corresponds to the selected content (right)

Creating tags for links that you made active late in the workflow
Note: If you have followed the Adobe PDF accessibility workflow that is described in this guide, the URLs and other links 
in the PDF document are probably already correctly tagged in the tag tree for accessibility, and you shouldn’t need to use 
this section. If, however, you added links to a tagged PDF document by using the Links tool or by applying the Create From 
URLs In Document command, follow the instructions in this section to complete the tagging for the links. 

To be accessible, each link in a PDF document must have three tags, presented in the following order, in the tag tree: 
a parent <Link> tag, a child Link OBJR tag, and a child document content tag. The <Link> tag alerts a screen reader 
to the presence of the link. The Link-OBJR tag enables screen readers to present the link. The document content tag 
identifies the content on the page that comprises the link.

When you use the Links tool or the Create From URLs In Document command on a tagged PDF document, Acrobat 
tags each URL by adding a document content tag to the tag tree, but it does not also add a <Link> tag nor a Link-
OBJR tag. A link that does not have a Link-OBJR tag is considered an unmarked link and is inaccessible to assistive 
technology. You must locate all instances of unmarked links in the tag tree, and then add <Link> and Link-OBJR 
tags to them, by following the instructions below.

 

An incompletely tagged link (left), which is missing its parent <Link> tag and its Link-OBJR tag. The same link properly tagged for  
accessibility (right).
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To find an unmarked link and add <Link> and Link-OBJR tags to it: 

1  In the Tags tab, choose Options > Highlight Content, and then choose Options > Find.

2  In the Find Element dialog box, select Unmarked Links from the Find drop-down menu. 

3  Click Find. The first unmarked link is highlighted on the page. 

4  Close the Find dialog box. Use the Select tool to select text that is near the link, then choose Options > Find Tag 
From Selection.

5  In the Tags tab, select the document content tag for the link (the tag that names the URL), and then choose 
Options > New Tag.

6  In the New Tag dialog box, select Link as the tag type and click OK. A <Link> tag appears below the selected 
document content tag. Drag the document content tag down to be the child of the <Link> tag.

7  Select the <Link> tag, choose Options > Find, and then select Unmarked Links from the Find drop-down menu.

8  Click Find. Acrobat finds the URL that you have been working with. 

9  In the Find Element dialog box, click Tag Element. The following two things happen: 

• A Link-OBJR tag appears as a child to the <Link> tag directly above the document content tag. The tagging for 
this link is complete.

• Acrobat highlights the next unmarked link in the document.

10  As needed, repeat steps 4 through 9 on the rest of the unmarked links in the document. 

To add alternate text to these links, see the following section, “Adding alternate text to links.” 

Adding alternate text to links
Screen readers can read the URLs of web links out loud, but adding meaningful alternate text to URL links can help 
users immensely. For example, by adding alternate text you can have a screen reader tell a user to go to “the Acrobat 
accessibility page of adobe.com” rather than go to “http://www.adobe.com/products/acrobat/solutionsacc.html.” 

You add alternate text to the <Link> tag of a link. See “Creating tags for links that you made active late in the 
workflow” on page 96 for instructions on adding a <Link> tag to links that may not have this tag.

Note: You must add alternate text only to tags that do not have child tags. Adding alternate text to a parent tag prevents 
a screen reader from reading any of that tag’s child tags.

To add alternate text to a link: 

1  In the tag tree, select the <Link> tag for the link and either:

• Choose Options > Properties.

• Open the context menu and choose Properties.

2  In the TouchUp Properties dialog box, select the Tag tab.

3  Type alternate text for the link, and click Close.
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Adding alternate text to a link by using the TouchUp Properties dialog box

Rearranging tags
When you insert or replace pages in a tagged Adobe PDF document, Acrobat adds the tags (if any) for the new pages 
at the end of the tag tree. For optimal accessibility, you should move the entire collection of tags for each new page 
in the tag tree to match the proper reading order in the document. This enables screen readers, the Read Out Loud 
tool, and the Save As Accessible Text feature to present the document in the right order. Doing this task is particularly 
important if you expect users to save the PDF content as accessible text for use with other systems, such as Braille 
translators. 

Rearranging tags in the tag tree is also a useful way to deal with PDF documents that contain articles that jump to 
later pages in the document—for instance, from page 3 to page 7 to finish a story. Articles that jump to later pages 
present an accessibility problem, because assistive technology generally reads a document page by page. By gathering 
all the tags that relate to a story in the same area of the tag tree, you enable assistive technology to present all the story 
text at once, in order, to the user. 

To simplify the task of rearranging tags for an entire page in the tag tree, collapse the tags to the page level and select 
the parent tag for the page. Drag or, if the tree is very long, cut and paste the parent tag to its new location. Be careful 
where you drop the tag; you may need to drag the tag left or right to keep it from being a child to the wrong tag. All 
child tags move with their parent tag.

For additional instructions on rearranging tags in the tag tree, see “Advanced tools for correcting tagging errors” in 
Acrobat 7.0 Help.

Deleting tags
When you replace or delete pages in a tagged Adobe PDF document, Acrobat retains all the tags that belonged to the 
pages that you removed. You should delete these obsolete tags so that assistive technology does not attempt to process 
them. Deleting extraneous tags reduces the document’s file size and improves Acrobat performance.  

Deleting tags is also useful when you need to clean up a portion of the tag tree before you create a new structure from 
scratch—for instance, if you want to tag a complex table by starting over.
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Note: There is no Undo command for the Tag tree, so be sure that you select the correct tag before you delete it.

To simplify the task of deleting tags for a page that is no longer in the document, collapse the tags to the page level 
and select the parent tag for the page that has been deleted. (Finding this tag may be tricky, because there is no longer 
any content to correspond to the obsolete tags, so you cannot use the Find Tag From Selection command. You may 
need to navigate the tag tree by using the Up and Down Arrow keys to find the tags for which Acrobat has nothing 
to highlight on a page.) 

When you delete a tag, Acrobat removes the tag and all of its child tags from the tag tree. If the associated page content 
is still in the document, the content becomes unmarked content. People who are using assistive technology will not 
know that the content is available.

To delete a tag element: 

1  In the tag tree, select the elements that you want to delete. 

2  Do one of the following: 

• In the Tags tab, choose Options > Delete Element. 

• Open the context menu for the selection, and then select Delete Element. 

• Press the Delete key.

Adding new tags
Using the TouchUp Reading Order tool is the easiest way to add tags to the tag tree from content that you select on 
the page. Sometimes, however, you may need to add other types of tags than the nine tags that the TouchUp Reading 
Order tool offers. 

In general, you must create new tags in the following three situations:

• To add intermediate parent tags (such as division, section, or table row tags) that have no specific content associated 
with them but that mark a document’s structure

• To add a child tag that is to have document content associated with it (such as links and cells for tables that you are 
tagging from scratch)

• To add a missing <Link> tag to a link that you tagged by using the Links tool or the Create From URLs In 
Document command on a tagged PDF document (as described in “Creating tags for links that you made active late 
in the workflow” on page 96)

Pay attention to what is currently selected in the tag tree before you create a tag. Acrobat places the new tag below 
the current selection, either as a peer tag or as a child tag. If you have nothing selected when you create a new tag, 
Acrobat places the new tag as the last child at the end of the tag tree. In either case, you probably need to drag (or cut 
and paste) the new tag into its proper hierarchy within the tree. 

To add tags that have no content associated with them:

1  Select a tag in the tag tree that is directly above where you want the new tag to be.

2  In the Tags tab, select Option > New Tag. 

3  Choose the tag type that you want to add, and then click OK.

4  Drag the element into its correct place in the tree.
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To add tags that are to have content associated with them:

1  Use the Select tool to select content on the page that immediately precedes the content for which you want to create 
a tag. Choose Options > Find Tag From Selection, and then select the parent tag of that content. (Doing this step 
helps you locate the new tag after you create it—Acrobat will place the new tag at the peer or child level in relation 
to the selected parent tag.)

2  Use the Select tool to select the content on the page that you want to tag.

3  In the Tags tab, select Options > Create Tag From Selection. 

4  As needed, drag the element into its correct place in the tree.

Note: Do not use this method to try to convert selected content to a link. Even though you can create a new <Link> tag 
for selected content, the content is not active and there is no real link. Instead, use the Select tool or the Snapshot tool to 
select specific content on the page, and then choose Create Link from the tool’s context menu. The Create Link command 
correctly activates the content and adds all the tags that screen readers need for reading links to users. See “Section 12: 
Adding other accessibility features” on page 85.

Adding expansion text to abbreviated terms 
Expansion text enables a screen reader to say the full phrase of an abbreviation or acronym, rather than attempting 
to pronounce the acronym or abbreviation. For example, instead of saying “USA,” a screen reader might read 
“United States” or “United States of America.” Expansion text is also useful to clarify the context for abbreviations 
or acronyms that can have different meanings in different contexts, such as “St.,” which can be both “Street” and 
“Saint.”

Adding expansion text involves creating a new document content tag for the abbreviation or acronym text, and then 
adding the expansion text to the new tag.

Note: You must add expansion text only to tags that do not have child tags. Adding expansion text to a parent tag prevents 
a screen reader from reading any of that tag’s child tags.

To add expansion text:

1  Using the Select tool, select the text to which you want to add expansion text.

2  In the Tags tab, choose Options > Find Tag From Selection.

3  Select the tag that is above the tag that Acrobat has found from the selection.

4  Choose Options > Create Tag From Selection. Acrobat splits the original content into three document content 
tags—one for the text that precedes your selection, one for the selection, and one for the text that follows the 
selection. 

5  As needed, drag the document content tag for the abbreviation into position between the other two tags, so that 
the text reads in the proper order. All three tags must also be at the same level beneath their parent tag. Drag them 
into place if they are not.

6  Select the document content tag for the abbreviation, choose Options > Properties, and then choose the Content 
tab. Type the expansion text. 
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Adding expansion text to an abbreviation or acronym creates three document content tags—one for the text that precedes the selection, one for 
the selection, and one for the text that follows the selection.

Setting the language for specific paragraphs or words
When a document in one language contains paragraphs or words that are in a different language, you can identify 
the use of another language in the tag tree so that an assistive technology can read the text in the other language. To 
tag a paragraph, you do not need to tag each word of the paragraph individually—just select the tag for a page 
element, and the language applies to all the text that is within that element. 

Acrobat includes 16 preset language selections. If you need to specify a language that is not on the list, such as 
Russian, you must type the ISO 639 code for the language, not its name. You can find the codes at 
www.loc.gov/standards/iso639-2/langhome.html.

To set the language for specific paragraphs:

1  Using the Select tool, select the paragraph for which you want to set the language.

2  In the Tags tab, choose Options > Find Tag From Selection.

3  With the tag selected, choose Options > Properties, and then show the Tag tab. Select the language from the drop-
down menu. 

To set the language for specific words:

1  Using the Select tool, select the text for which you want to set the language.

2  In the Tags tab, choose Options > Find Tag From Selection.

3  Select the tag that is above the tag that Acrobat has found from the selection.

4  Choose Options > Create Tag From Selection. Acrobat splits the original content into three document content 
tags—one for the text that precedes your selection, one for the selection, and one for the text that follows the 
selection. 

5  As needed, drag the document content tag for the selected text into position between the other two tags, so that 
the text reads in the proper order. All three tags must also be at the same level beneath their parent tag. Drag them 
into place if they are not.

6  Select the document content tag for the selected text, choose Options > Properties, and then choose the Tag tab. 
Select the language from the drop-down menu. 

www.loc.gov/standards/iso639-2/langhome.html
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Making tables accessible
Tables of text or data pose a special challenge for screen readers and other assistive technology, because content in a 
table is meant to be read both across and down. To enable screen readers to present the content in a logical reading 
order, you must properly tag the table structure. 

The Add Tags To Document feature in Acrobat 7.0 has difficulty recognizing many kinds of tables as tables, and 
therefore often does not tag them properly. Tagging an Adobe PDF document during conversion from an authoring 
application often provides better results, but the document may still warrant close scrutiny of any table that is more 
than a simple grid. 

Problems with table structure can occur for many reasons, including the following:

• The table lacks rules that define its boundaries, columns, rows, and cells, and instead uses white space to organize 
data.

• The author formatted the table by using tab stops instead of the table features that were available in the authoring 
application.

• The table cells contain complex information, such as multiple paragraphs, bulleted lists, form fields, links, or text 
that is deeper than one page.

• The table has cells that have been merged so that one cell spans two or more columns, or one cell spans two or more 
rows.

Understanding the proper hierarchy of a table
The proper embedding of <TR>, <TH>, and <TD> tags in the tag tree provides the structure that assistive 
technology needs in order to move from cell to cell properly. A table should have the following hierarchy of elements: 

• A table tag <Table>, which has attributes that specify the placement and bounding box information for the table.

• One or more table row tags <TR>, which define each row of table cells as immediate child tags of the <Table> tag.

• One or more table data tags <TD> or table header tags <TH> as the immediate child tags of each table row 
element; <TH> tags must always be at the same level as <TD> tags for the same row.

Note: To support assistive technology effectively, you must specifically mark table header cells as <TH>, not as <TD>. 

A B

1 A-1 B-1

2 A-2 B-2

<Table>
<TR>

<TH> [empty]
<TH> A
<TH> B

<TR>
<TH> 1
<TD> A-1
<TD> B-1

<TR>
<TH> 2
<TD> A-2
<TD> B-2

 
A simple table (top), and how its tags should look in the tag tree (bottom)
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Incorrect tagging structure for a table (top) and the corrected tagging structure for the table (bottom). The corrected structure has <TH> tags 
for all header cells, including <TH> tags that are at the same level as the <TD> tags for rows that contain both types of cells. 

Tables that are a straightforward grid provide the greatest accessibility. That is, each row has the same number of 
columns, and each column has the same number of rows. Many tables, however, merge cells to make a single cell 
span two or more columns or rows. Merging cells across columns or down rows creates problems for screen readers 
unless you properly assign ColSpan and RowSpan attributes to the <TH> or <TD> tag of the merged cell. These 
attributes tell the screen reader how many columns or rows a particular cell spans (such as ColSpan=3 for a cell that 
is three columns wide, or RowSpan=2 for a cell that is two rows deep).

For tables that contain blank cells, you may also need to add empty <TD> cells into the tree structure, so that each 
row or column has the same number of cells. This enables the screen reader to present the content in a way that 
doesn’t confuse the user.
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The workflow for tagging tables
The easiest way to tag tables is to start by using the TouchUp Reading Order tool and finish by editing the tag tree. 
For instructions on using the TouchUp Reading Order tool, see “Section 11: Repairing reading order and basic 
tagging problems” on page 59. The general workflow is as follows:

1  Use the TouchUp Reading Order tool to mark the beginning and end of the table. Acrobat adds a <Table> tag to 
the tag tree and analyzes the table to apply <TD> tags for the cells that it can interpret.

2  If cells have been incorrectly merged or split, use the TouchUp Reading Order tool to tag each cell individually.

Note: The Cell button of the TouchUp Reading Order tool tags all cells as <TD> cells. If some of these tags should be 
<TH>, you must edit them in the tag tree. 

3  Verify that the appropriate <TR>, <TH>, and <TD> tags are in the proper reading order and hierarchy in the tree. 
If they are not, edit the tag tree in the following ways:

• Drag existing tags into the proper reading order and hierarchy. Put <TH> tags at the same level as <TD> tags 
for the same row.

• Rename incorrectly tagged <TD> tags to <TH>. (Type over the name of the tag.)

• Add empty <TD> or <TH> tags for any cells in the table that are blank. (See “Understanding the proper 
hierarchy of a table” on page 102.)

• Add ColSpan and RowSpan attributes to any <TH> or <TD> tags that represent merged cells. (For instructions, 
see “Advanced tools for correcting tagging errors” in Acrobat 7.0 Help.)

Note: When you are working with table tags, use the TouchUp Text tool (not the Select tool) to select table content on the 
page. Using the Select tool on a table selects the whole table. Using the TouchUp Text tool enables you to select a particular 
cell, so that you can find its tag directly in the tag tree by using Options > Find Tag From Selection.

Checking and fixing the reading order of complex pages
After you have used the TouchUp Reading Order tool on complex pages, you may want to verify the final reading 
order of certain highlighted regions, such as on multicolumn or highly designed pages. If the content isn’t in the right 
reading order, you can drag the document content tags into the proper order in the tag tree. Moving tags in the tag 
tree has no effect on the highlighted regions that you see when you use the TouchUp Reading Order tool or the Order 
tab, but it ensures that screen readers can present the text in the proper order. 

This technique enables you to use the Up and Down Arrow keys in the tag tree and highlight the content in the order 
that the tags appear.

Note: You can also use the technique below to skim the contents of a page and check the logical reading order without using 
a screen reader.

1  Open the Tags tab and Ctrl+click (Windows) or Option+click (Mac OS) on the plus sign of the Tags root to 
expand all the tags.

2  Go to Fit In Window view.

3  From the Tags tab, choose Options > Highlight Content.

4  Starting at the root (or at the first tag of a page that you want to check), use the Down Arrow key to highlight each 
tag in turn and check that its corresponding content on the page is in the logical reading order. 

5  If you find content that is out of logical reading order, drag the document content tag for that content into the 
proper location in the tag tree by following the instructions in “Rearranging tags” on page 98.
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Using the tag tree to verify the reading order of a complex section of a page—the three paragraphs are indeed in the correct order (top),  
even though their highlighted regions overlap on the page when you use the TouchUp Reading Order tool (bottom).
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Appendix: Standard tags for Adobe 
PDF documents

This section describes the standard tag types that apply to tagged Adobe PDF documents. These standard tags 
provide assistive technology with a base set of concepts to use in interpreting document structure and presenting 
content logically to a user.

The information in this section applies to Acrobat 7.0 Professional and Acrobat 7.0 Standard.

An extensible tags architecture
The PDF tags architecture is extensible, so any Adobe PDF document can contain any tag set that an authoring  
application decides to use. For instance, a PDF document might have XML tags that came in from an XML schema. 
Any custom tags that you define (such as tag names that were generated from paragraph styles from an authoring 
application) should have a role map that matches each custom tag to one of the standard tags here. When assistive 
technology comes across a custom tag, the technology can refer to this role map and properly interpret the tags. 
Tagging PDF documents by using one of the methods described in this guide generally produces a correct role map 
for the document. 

Note: You can view and edit the role map of a PDF document by choosing Options > Edit Role Map in the Tags tab. 

The following standard Adobe element tag types are available in the New Tag dialog box and in the TouchUp 
Properties dialog box in Acrobat Professional. 

Adobe strongly encourages using these tag types, because they provide the best results when you or a user must 
convert the tagged content to a different format, such as HTML, Microsoft Word, or an accessible text format for use 
by other types of assistive technology. 

Block-level elements
Block-level elements are page elements that consist of text that is laid out in paragraph-like forms. Block-level 
elements are part of the document’s logical structure. Such elements are further classified as container elements, 
heading and paragraph elements, label and list elements, special text elements, and table elements. 

Container elements
Container elements are the highest level of element and provide hierarchical grouping for other block-level elements:

• Document element <Document> — The root element of a document’s tag tree 

• Part element <Part> — A large division of a document; may group smaller units of content together, such as 
division elements, article elements, or section elements 

• Division element <Div> — A generic block-level element or group of block-level elements 

• Article element <Art> — A self-contained body of text considered to be a single narrative 

• Section element <Sect> — A general container element type, comparable to Division (DIV Class=“Sect”) in 
HTML, which is usually a component of a part element or an article element 



107ADOBE ACROBAT 7.0
Appendix: Standard tags for Adobe PDF documents

Heading and paragraph elements
Heading and paragraph elements are paragraph-like, block-level elements that include specific level headings and 
generic paragraphs <P>. A heading element <H> should appear as the first child of any higher level division. Six 
levels of headings <H1 to H6> are available for applications that don’t hierarchically nest sections.

Label and list elements
Label and list elements are block-level elements that are used for structuring lists: 

• List element <L> — Any sequence of items of similar meaning or other relevance; immediate child elements should 
be list item elements

• List item element <LI> — Any one member of a list; may have a label element (optional) and a list body element 
(required) as a child

• Label element <LBL> — A bullet, name, or number that identifies and distinguishes an element from others in the 
same list

• List body element <LBody> — The descriptive content of a list item

Special text elements
Special text elements identify text that is not used as a generic paragraph (<P>): 

• Block quote element <BlockQuote> — One or more paragraphs of text attributed to someone other than the 
author of the immediate surrounding text

• Caption element <Caption> — A brief portion of text that describes a table or a figure

• Index element <Index> — A sequence of entries that contain identifying text and reference elements that point out 
the occurrence of the text in the main body of the document

• Table of contents element <TOC> — An element that contains a structured list of items and labels identifying those 
items; has its own discrete hierarchy

• Table of contents item element <TOCI> — An item contained in a list associated with a table of contents element

Table elements
Table elements are special elements for structuring tables: 

• Table element <Table> — A two-dimensional arrangement of data or text cells that contains table row elements as 
child elements and may have a caption element as its first or last child element

• Table row element <TR> — One row of headings or data in a table; may contain table header cell elements and 
table data cell elements

• Table data cell element <TD> — A table cell that contains nonheader data

• Table header cell element <TH> — A table cell that contains header text or data describing one or more rows or 
columns of a table
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Inline-level elements
Inline-level elements identify a span of text that has specific formatting or behavior. They are differentiated from 
block-level elements, and may be contained in, or contain, block-level elements. The standard inline-level elements are: 

• Bibliography entry element <BibEntry> — A description of where some cited information may be found

• Quote entry element <Quote> — An inline portion of text that is attributed to someone other than the author of 
the text surrounding it; different from a block quote, which is a whole paragraph or multiple paragraphs, as 
opposed to inline text

• Span entry element <Span> — Any inline segment of text; commonly used to delimit text that is associated with a 
given set of styling properties

Special inline-level elements
Similar to inline-level elements, special inline-level elements describe an inline portion of text that has special 
formatting or behavior: 

• Code entry element <Code> — Computer program text embedded within a document 

• Figure entry element <Figure> — A graphic or graphic representation associated with text 

• Form entry element <Form> — A PDF form annotation that can be or has been filled out 

• Formula entry element <Formula> — A mathematical formula 

• Link entry element <Link> — A hypertext link that is embedded within a document and that is associated with an 
annotation that goes to another place in the same document or in another document, or to a website

• Note entry element <Note> — Explanatory text or documentation, such as a footnote or endnote, that is referred 
to in the main body of text 

• Reference entry element <Reference> — A citation to text or data that is found elsewhere in the document 
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